Zahl im umgewandelten Wert liefern

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Zahl im umgewandelten Wert liefern
von: Harald
Geschrieben am: 21.09.2003 12:40:14

Hallo,

ich suche nach einer Möglichkeit eine negative Zahl (A1) in einer anderen Zelle (A2) als positive Zahl darzustellen. Ich habe bisher herausgefunden, dass es mit der Funktion "N" in Excel geht. Ich will aber nur dann die Zahl umwandeln lassen, wenn der Zahlenwert in der Zelle (A1) wirklich negativ ist! Ansonsten soll der Zahlenwert Null sein.

Skizze:
----------------------------------
| | A | B | C
-----------------------------------
|1| - 1.200 € | |
|2| =N() // Bedingung wenn A1 negativ, sonst Wert=Null
|3| | |
|4| | |

Wer hat hier eine Idee?

Gruß
Harald

Bild


Betrifft: AW: Zahl im umgewandelten Wert liefern
von: Ramses
Geschrieben am: 21.09.2003 12:46:51

Hallo

=WENN(A1<0;ABS(A1);0)

Gruss Rainer


Bild


Betrifft: AW: Zahl im umgewandelten Wert liefern
von: Harald
Geschrieben am: 21.09.2003 12:59:50

Hallo Rainer,

vielen Dank, so habe ich mir es vorgestellt.

Noch einen schönen Sonntagnachmittag wünscht

Harald aus Berlin


Bild


Betrifft: AW: Negative Zahl -> positive Zahl : Null
von: Franz Pölt
Geschrieben am: 21.09.2003 16:21:01

Hallo Harald,

2 zusätzliche Möglichkeiten ohne WENN bzw. leicht modifizierte Möglichkeit á la Ramses:

Excel Jeanie HTML
Formeln der Tabelle
B2 : =(A2<0)*ABS(A2)
C2 : =(A2<0)*A2*-1
D2 : =WENN(A2<0;ABS(A2);)
B3 : =(A3<0)*ABS(A3)
C3 : =(A3<0)*A3*-1
D3 : =WENN(A3<0;ABS(A3);)
B4 : =(A4<0)*ABS(A4)
C4 : =(A4<0)*A4*-1
D4 : =WENN(A4<0;ABS(A4);)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

 Bild

Beiträge aus den Excel-Beispielen zum Thema " Zahl im umgewandelten Wert liefern"