Das Archiv des Excel-Forums

Zahlen trennen

Bild

Betrifft: Zahlen trennen
von: Alex

Geschrieben am: 24.09.2003 13:42:04

Hallo,

vielleicht kann mir jemand bei folgendem Problem helfen:

Ich möchte zwei Tabellen via SVerweis füllen. Das Suchkriterium in beiden Tabellen sind fünf zahlen. Allerdings haben die zahlen in der tabelle die form 100 00 und in der anderen die form 10000. Deshalb findet der SVerweis keine übereinstimmenden Daten.
Daher meine Frage : Wie kann ich die Zahlenform 10000 in die Form 100 00 überführen ohne jede manuell ändern zu müssen ??

Danke für die Hilfe
Bild


Betrifft: AW: Zahlen trennen
von: Hajo_Zi
Geschrieben am: 24.09.2003 13:46:49

Hallo Alex

Welche Teil enthält die Leerstelle, Der Suchbegriff?? dann dürfte Wechseln die Lösung sein.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: andersrum
von: th.heinrich
Geschrieben am: 24.09.2003 13:58:12

hi Alex,

warum nicht mit BEARBEITEN-ERSETZEN das LEERZEICHEN entfernen ?

nach SVERWEIS kannst Du immer noch FORMATIEREN.

gruss thomas


Bild


Betrifft: AW: Zahlen trennen
von: Johannes Haseitl
Geschrieben am: 24.09.2003 14:06:25

Hallo Alex,

wenn die Leerstelle immer zw. 3. und 2. Stelle ist (und die Zahl immer aus 5 Stellen besteht) klappt es mit der Formel:
=LINKS(A1;3)&" "&RECHTS(A1;2)
dabei steht in A1 die umzuwandelne Zahl.

Gruß Johannes


Bild


Betrifft: AW: Zahlen trennen
von: Panicman
Geschrieben am: 24.09.2003 15:37:33

Hallo Alex

so klappt es:




Formel B2 =SVERWEIS(TEXT(A1;"### ##");C1:D1;2)
Formel B3 =SVERWEIS(WERT(WECHSELN(A2;" ";""));C2:D2;2)

Gruß
Holger


 Bild

Excel-Beispiele zum Thema " Zahlen trennen"

Vorkommen von Zahlenreihen in Spalten download Zeichenfolgen in Zahlen nach Textimport download
Zahlenformatierung mit Punkt nach der 1. Ziffer download Namen von TextBoxes hochzählen download
Zählen formatierter Zellen download Autofilter auch mit Ziffern von Zahlen download
Addition der absoluten Zahlen download Eingabe von positiven Zahlen erzwingen download
Zufallszahlen generieren, die sich nicht wiederholen download Summenformel unter Zahlenreihe eintragen download
Nur AJM in TextBox akzeptieren und Anzahl zählen download Teilergebnisse in Zahlenreihe eintragen und löschen download
Nach Textimport Strings in Zahlen wandeln download Alle Formeln und Zahlen löschen download
Werte nur mit Zahlenformaten übertragen download Worte in einem vorgegebenen Bereich zählen download
Anzahl in einer Liste vorkommender Namen zählen download Zellwerte über SpinButton und ScrollBar hochzählen download
Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download Label in Zelle A1 bei jedem Ausdruck um 1 hochzählen download
Anzahl Artikelnummern auf Deckblatt nach Blättern zählen download Als Text vorhandene Werte in Zahlen umwandeln download
Den jeweils letzten Wert einer Zahlenreihe als Multiplikator download Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download
Lottozahlen-Generator download Lücken aus Zahlenreihe listen download
Zahlen in Abhängigkeit von ihrem Wert multiplizieren download Gleiche Zufallszahlen zählen und in Diagramm anzeigen download
Zufallszahlen bis zum 4-fachen Wert generieren download Reihenfolge einer Zahlenreihe nach dem Zufallsprinzip variieren download
Anzeige eines Zahlwortes synchron zur Textbox-Zahleneingabe download Zahlen unter Berücksichtigung von Monat und Jahr summieren download
Tabelle gem. hinterlegten Zahlenformaten formatieren download Zählen von in einer Formel vorkommenden Zahlen download
Addition der 10 höchsten Werte einer Zahlenreihe download Spaltenbreite gemäß den in den Zellen stehenden Zahlen festlegen download
Zeilen zählen, in denen zwei Bedingungen zutreffen download Leerzeichen zwischen Zeichen- und Zahlenfolge entfernen download
Alle Zellen mit einer vorgegebenen Hintergrundfarbe zählen download Zahlen eines Bereiches jeweils 4 mal in eine Spalte schreiben. download
Kennzeichnung von Lottogewinnzahlen download Strings, die wie Zahlen aussehen, in Zahlen umwandeln download
Zahlen-Formatierungs-Dialog aus UserForm aufrufen download Zahlenmarkierungen in einer Lottoliste download
Datensätze zählen, die in einigen Spalten identisch sind download Zeit in vorgegebenem Intervall hochzählen download
Alle ungeraden Zahlen markieren download Zeichen als Zahlen darstellen download
Teilungszahlen und Sitzfolge nach dem Höchstzahlverfahren download Eingeblendete Zeilen mit Werten zählen download
Zellen verbinden und trennen download Postleitzahl vom Ort trennen download
Hyperlinks in Text, Adresse und Sub-Adresse trennen download Internetverbindung trennen download
Unterschiedliche Namen mit Rahmenlinien trennen download