Zahlen trennen

Bild

Betrifft: Zahlen trennen
von: Alex
Geschrieben am: 24.09.2003 13:42:04

Hallo,

vielleicht kann mir jemand bei folgendem Problem helfen:

Ich möchte zwei Tabellen via SVerweis füllen. Das Suchkriterium in beiden Tabellen sind fünf zahlen. Allerdings haben die zahlen in der tabelle die form 100 00 und in der anderen die form 10000. Deshalb findet der SVerweis keine übereinstimmenden Daten.
Daher meine Frage : Wie kann ich die Zahlenform 10000 in die Form 100 00 überführen ohne jede manuell ändern zu müssen ??

Danke für die Hilfe

Bild


Betrifft: AW: Zahlen trennen
von: Hajo_Zi
Geschrieben am: 24.09.2003 13:46:49

Hallo Alex

Welche Teil enthält die Leerstelle, Der Suchbegriff?? dann dürfte Wechseln die Lösung sein.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: andersrum
von: th.heinrich
Geschrieben am: 24.09.2003 13:58:12

hi Alex,

warum nicht mit BEARBEITEN-ERSETZEN das LEERZEICHEN entfernen ?

nach SVERWEIS kannst Du immer noch FORMATIEREN.

gruss thomas


Bild


Betrifft: AW: Zahlen trennen
von: Johannes Haseitl
Geschrieben am: 24.09.2003 14:06:25

Hallo Alex,

wenn die Leerstelle immer zw. 3. und 2. Stelle ist (und die Zahl immer aus 5 Stellen besteht) klappt es mit der Formel:
=LINKS(A1;3)&" "&RECHTS(A1;2)
dabei steht in A1 die umzuwandelne Zahl.

Gruß Johannes


Bild


Betrifft: AW: Zahlen trennen
von: Panicman
Geschrieben am: 24.09.2003 15:37:33

Hallo Alex

so klappt es:




Formel B2 =SVERWEIS(TEXT(A1;"### ##");C1:D1;2)
Formel B3 =SVERWEIS(WERT(WECHSELN(A2;" ";""));C2:D2;2)

Gruß
Holger


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Zahlen trennen"