Laufzeitfehler bei Office 200

Bild

Betrifft: Laufzeitfehler bei Office 200
von: sarah
Geschrieben am: 24.09.2003 15:49:17

Hallo zusammen,

habe eine lauffähige Prozedur unter Office 97, die den Befehl "Date" beinhaltet.

Gleiche Prozedur unter 2000 bringt Laufzeitfehler: Date ist im unbekannt.
Bisher lief alles; Das komische: Erst nach einer Änderung funktioniert es nicht mehr.

Ich dies ein zufälliger Fehler oder steckt da ein behebbares Schema dahinter.
Hatte vor kurzem gleiches Problem mit dem Befehl "Right"

Erst durch komplett neues Aufbauen habe ich das Ding wieder zum Laufen gekriegt.

Ähnliche Porbleme oder Lösung.. dann freue ich mich auf Antwort

gruss
sarah :-|

Bild


Betrifft: AW: Laufzeitfehler bei Office 200
von: Hajo_Zi
Geschrieben am: 24.09.2003 16:12:14

Hallo Sarah

hast Du in VBA Verweise abgewählt. in XP sind folgende aktiv. Du müßtest bei Dir nur die entsprechende Version Nr. haben.

http://home.media-n.de/ziplies/verweise.gif



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Laufzeitfehler bei Office 200
von: sarah
Geschrieben am: 24.09.2003 16:30:51

Hallo Hajo:

Dank' Dir für die Lösung; Das mit dem Verweis war die Lösung.
Was ich nicht versteh' ist, dass ein simpler Befehl "verloren" geht?

Aber gut; die Funktion zählt.

sarah :-)


Bild


Betrifft: Danke für die Rückmeldung
von: Hajo_Zi
Geschrieben am: 24.09.2003 16:49:36

Hallo Sahrah

die Befehle werden in Bibliotheken verwaltet und das sind die Verweise und wenn eine Bibliothek nicht geladen wird kann er auch den Befehl nicht finden.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: OK...
von: sarah
Geschrieben am: 24.09.2003 17:10:26

OK..

Die Funktion ist mir jetzt klar; Aber wie sieht dann ein korrektes Vorgehen aus?
Ich erstelle eine Funktion, die auf unterschiedlichen Systemen (von 97 aufwärts) laufen soll.

Wie stelle ich sicher das alles "Nötige" mitgeliefert wird. Anders: was sind Standardpakete die immer laufen.

Ich hab mich auf 97 versteifft, weil ich mir gedacht habe; aufwärts wird'schon geh'n.
Dann ist der Ansatz wohl nicht der Beste..

gruss
sarah


Bild


Betrifft: AW: Verweise
von: Hajo_Zi
Geschrieben am: 24.09.2003 17:24:24

Hallo Sarah

mit dem Problem habe ich mich noch nicht befast. Laut MS soll alles aufwärtskompatibel sein. Ich habe auch mit 97 angefangen und die Programm laufen bei mir auch unter XP.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



 Bild

Beiträge aus den Excel-Beispielen zum Thema " Laufzeitfehler bei Office 200"