Herbers Excel-Forum - das Archiv

Bereiche auszählen

Bild

Betrifft: Bereiche auszählen
von: Didi
Geschrieben am: 24.09.2003 17:37:26
Hallo,

ich habe den Zellen A1:A10 und den Zellen A11:A20 Bereichsnamen (GruppeA) und (GruppeB) zugeteilt.

In GruppeA wird nur der Buchstabe A in GruppeB nur der Buchstabe B eingetragen.
Wie kann ich per Makro zählen, wieoft die Buchstabe A oder B vorhanden sind und wenn, A oder B nur zweimal vorhanden ist eine Warnung ausgeben?

Danke im Voraus

Gruß Didi

Bild

Betrifft: AW: Bereiche auszählen
von: Frank
Geschrieben am: 24.09.2003 17:47:16
Hallo

ich habe nicht viel Ahnung!
kann das seine, dass es mit =summewenn...
funktioniert
Bild

Betrifft: AW: Bereiche auszählen
von: Didi
Geschrieben am: 24.09.2003 17:54:04
Soll aber per Makro ausgezählt werden!
Bild

Betrifft: AW: Bereiche auszählen
von: th.heinrich
Geschrieben am: 24.09.2003 18:05:37
hallo Didi,

warum immer MAKRO, wenns auch mit bordmitteln geht.

beispiel fuer SPALTE A

FORMEL steht in C1, Suchkriterium a in D1

=ZÄHLENWENN(A2:A6;D1).

zusaetzlich in C1 FORMAT-BEDINGTE FORMATIERUNG-ZELLWERT-IST GLEICH 2.

gruss thomas
Bild

Betrifft: AW: Bereiche auszählen
von: Didi
Geschrieben am: 24.09.2003 18:19:09
Hallo,

Eine Formel hilft mir nicht weiter: Aus den benannten Bereichen werden manchmal Zeilen per Makro gelöscht!
Also brauch ich eine Warnung, wenn Buchstabe A oder Buchstabe B nur noch zweimal vorhanden ist.
Bild

Betrifft: AW: Bereiche auszählen
von: th.heinrich
Geschrieben am: 24.09.2003 18:38:27
hallo Didi,

bitte immer dem antworter antworten und nicht auf Dein posting. wird sonst zu unuebersichtlich. keiner weiss wem Du antwortest.

bei meinem vorschlag darf nur 1:1 nicht geloescht werden.

gruss thomas

ps. wenn mit MAKRO dann kann vorhandener CODE nicht schaden.
Bild

Betrifft: AW: Bereiche auszählen
von: Boris
Geschrieben am: 24.09.2003 21:03:22
Hi Didi,

Option Explicit

Sub machwas()
Dim A As Long, B As Long
Dim C As Range
Dim C1 As Range
Set C = Range("GruppeA")
Set C1 = Range("GruppeB")
A = WorksheetFunction.CountIf(C, "A")
B = WorksheetFunction.CountIf(C1, "B")
If A > 2 And B > 2 Then
MsgBox "A:" & A & " mal" & Chr(10) & _
"B:" & B & " mal", , "Melde Vollzug:"
Else
MsgBox "A oder B ist weniger als 3 mal vorhanden", , "Warnung"
End If
End Sub


Grüße Boris
 Bild
Excel-Beispiele zum Thema " Bereiche auszählen"
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche Bereiche bei Mehrfachauswahl prüfen
Auswahl eines Zellbereiches verhindern Bereiche in Abhängigkeit eines Zellinhaltes drucken
URLs eines ausgewählten Bereiches in HyperLinks umwandeln Berechnung des ausgewählten Bereiches in der Statusleiste
Bereiche auf Übereinstimmung vergleichen Werte eines bestimmten Wochentages und eines Zeitbereiches addieren
Datenreihenbeschriftungs-Quellbereich ausserhalb des Datenbereiches Namen eines ausgewählten Bereiches auslesen