Microsoft Excel

Herbers Excel/VBA-Archiv

Zeitplanung

    Betrifft: Zeitplanung von: Til
    Geschrieben am: 29.09.2003 09:37:34

    Hallo!

    Ich finde so recht den Einstieg nicht und benötige Hilfe…

    Ich möchte eine Datei erstellen, die folgendes leisten kann:

    Sie besteht aus 4 Spalten. In die erste kommt lediglich Text. Dieser Text bezeichnet einen Auftrag. In die zweite Spalte kommt eine Startzeit; bspw. 10:00 Uhr. Dann möchte ich noch die Dauer für die Bearbeitung des Auftrags eingeben, bspw. 3 Stunden. Dieser Wert kommt in die dritte Spalte. Jetzt soll in der vierten Spalte automatisch von Excel berechnet "15:OO" stehen.

    Für den nächsten Auftrag muss dann als Startbeginn in der zweiten Zeile und der zweiten Spalte die "15.00" stehen. Ich möchte dann wieder eine Auftragsdauer eingeben. Diesmal zum Beispiel 12 Stunden. Dann bin ich einen Tag weiter, und es ist morgen 3 Uhr. Auch das muss Excel erkennen und in der 4. Spalte wiederum als Wert eintragen – es darf dann auch wirklich nur mit den 24 Stunden arbeiten.

    Und so soll das dann immer weiter gehen…

    Und – hat einer einen Tip für mich? Wenn es zu kompliziert mit der Erklärung wird – ich freue mich auch über eine kleine Demo-Datei an meine Adresse…

    Email: Tielko.de.Groot@skn.info (da das Beitrags-Formular keine 4 Buchstaben als Domain verkraftet)

    … und im Optimalfall würde dann noch in der 5. Spalte jeweils ein "Mo", "Di" usw für den aktuellen Tag, angelehnt an die Einträge in der Liste, erscheinen… ;–)

      


    Betrifft: AW: Zeitplanung von: HerbertH
    Geschrieben am: 29.09.2003 11:35:20

    Hallo Til,
    Diese Formeln eingeben und runterziehen...

     ABCDE
    1ABCD10:005,0015:00Mo
    2EFGH15:0012,003:00Mo
    3  =WENN(A3="";"";D2)  =WENN(C3="";"";B3+(C3/24)) 
    4     
    5     



    Dieses Ereignismakro in das Tabellenmodul kopieren...
    rechte Maustaste auf Blattregisterkarte/Code anzeigen/Code reinkopieren
    in der Spalte "E" dieses Format festlegen: TTT

    Option Explicit
    Private Sub Worksheet_Change(ByVal Target As Range)
     If Not Intersect(Target, Range("a1:a1000")) Is Nothing Then
     ActiveCell.Offset(0, 4) = Date
    End If

    If ActiveCell = "" Then
     ActiveCell.Offset(0, 4) = ""
    End If
    End Sub

    Gruß Herbert