Das Archiv des Excel-Forums

Trennung von Einträgen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Trennung von Einträgen
von: Michi

Geschrieben am: 30.09.2003 09:06:26

Moin @all,

eine Problem bzw Frage:

Kann ich bestimmte Einträge aufsplitten? Es geht um die Straße und die Hausnumme. Ich will die in einem Feld in meiner UserForm (VBA ein wenig) eingeben und in der Tabelle soll sie aufgesplitte werden nach Straße - Hausnummer - Hausnummerzusatz

Beispiel:
Leonberger-Straße 3-5

Tabelle1
 BCD
2STRASSEHAUS_NRZUSATZ
3   
4Leonberger-Straße3-5
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   ist das machbar per Schleife oder so? Danke Michi
Bild


Betrifft: AW: Trennung von Einträgen
von: Hajo_Zi
Geschrieben am: 30.09.2003 09:27:30

Hallo Michi

mal als Ansatz

Straße von Hausnummer trennen
in D1 für die Hausnummer steht also die Array-Formel:
{=TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;SPALTE(1:1);1)*1);0);LÄNGE(A1))*1}
in C1 für den Straßennamen steht:
=LINKS(A1;LÄNGE(A1)-LÄNGE(D1))
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluss der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.
Von WF

Straße des 17. Juni 23
dann nimm:
{=TEIL(RECHTS(A1;4);VERGLEICH(WAHR;ISTZAHL(TEIL(RECHTS(A1;4);SPALTE(1:1);1)*1);0);LÄNGE(RECHTS(A1;4)))*1}
Über 4-stellige Hausnummern gibt's ja wohl nicht; und die Formel versagt dann nur, wenn der "Name" mit einer Zahl endet.
in C1 für den Straßennamen steht:
=LINKS(A1;LÄNGE(A1)-LÄNGE(D1))
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluss der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.
Von WF



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Trennung von Einträgen
von: Michi
Geschrieben am: 30.09.2003 09:41:16

Hallo Hajo,

danke für den Ansatz ...

Michi

Das blöde ist wirklich, das hier in meinem Beispiel die Hausnummer und der Zusatz mit "3-5" steht. Und damit berechnet Excel - aber dann muss ich mir etwas anderes einfallen lassen!

Danke


Bild


Betrifft: AW: Trennung von Einträgen
von: Hajo_Zi
Geschrieben am: 30.09.2003 10:05:31

Hallo Michi

schreibe die Hausnummer erst in eine Hilfsspalte.

Tabelle1
 BCD
1544 
161-212
Formeln der Tabelle
C15 : =WENN(LÄNGE(B15)=LÄNGE(WECHSELN(B15;"-";""));B15;LINKS(B15;FINDEN("-";B15)-1))
D15 : =WENN(B15=C15;"";RECHTS(B15;LÄNGE(B15)-FINDEN("-";B15)))
C16 : =WENN(LÄNGE(B16)=LÄNGE(WECHSELN(B16;"-";""));B16;LINKS(B16;FINDEN("-";B16)-1))
D16 : =WENN(B16=C16;B16;RECHTS(B16;LÄNGE(B16)-FINDEN("-";B16)))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.
Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen. Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen. Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet. Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.
http://home.media-n.de/ziplies/

Bild


Betrifft: AW: Trennung von Einträgen
von: Michi
Geschrieben am: 30.09.2003 10:15:13

Hallo Hajo,

super - vielen Dank dafür! Echt klasse :-)

cu
Michi


 Bild