Namen auslesen

Bild

Betrifft: Namen auslesen
von: Mimi
Geschrieben am: 30.09.2003 14:25:00

Hallo Leute...
In der Spalte C habe ich 300 Namen, manche doppelt.
Jetzt möchte ich per Makro jeden Namen EINMAL!! filtern
und dann nach Filterung "C2:f2" kopieren!

Das Filtern und kopieren ist nicht nicht entscheidend!
Wichtig ist, wie kann ich jeden Namen, der in der Liste vorkommt
in mein Makro mit einfliessen lassen? der Filterpunkt liegt in der
Zelle "b6"

Vielen Dank
Michael

Bild


Betrifft: AW: Namen auslesen
von: Hajo_Zi
Geschrieben am: 30.09.2003 16:29:18

Hallo Michael

Leider lese ich aus Deiner Beschreibung nicht so klar was Du willst.

Tabelle1
 AB
1Test112
2Test213
3Test114
4Test415
5Test516
6Test617
7Test718
8Test719
9Test320
10Test321
11Test422
12Test523
13Test324
14Test725
15Test122
16Test227
1712. Mai28
1812. Mai29
19Test530
20Test631
21Test732
 
Tabelle2
 ABC
1Test116Formel Spalte D von http://www.excelformeln.de/formeln.html?welcher=194
2Test220Mittelwerte der Werte aus Tabelle 1 von Spalte B, je nach Wert der Spalte A
3Test418,5 
4Test523 
5Test624 
6Test723,5 
7Test321,6666667 
812.5.0328,5 
9   
10   
Formeln der Tabelle
A1 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B1 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A1;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A1));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A1;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A1))
A2 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B2 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A2;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A2));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A2;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A2))
A3 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B3 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A3;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A3));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A3;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A3))
A4 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B4 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A4;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A4));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A4;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A4))
A5 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B5 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A5;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A5));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A5;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A5))
A6 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B6 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A6;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A6));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A6;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A6))
A7 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B7 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A7;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A7));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A7;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A7))
A8 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B8 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!$A$1:$A$21;A8;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A8));"";SUMMEWENN(Tabelle1!$A$1:$A$21;A8;Tabelle1!$B$1:$B$21)/ZÄHLENWENN(Tabelle1!$A$1:$A$21;A8))
A9 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B9 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!A9:A29;A9;Tabelle1!B9:B29)/ZÄHLENWENN(Tabelle1!A9:A29;A9));"";SUMMEWENN(Tabelle1!A9:A29;A9;Tabelle1!B9:B29)/ZÄHLENWENN(Tabelle1!A9:A29;A9))
A10 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))}
B10 : =WENN(ISTFEHLER(SUMMEWENN(Tabelle1!A10:A30;A10;Tabelle1!B10:B30)/ZÄHLENWENN(Tabelle1!A10:A30;A10));"";SUMMEWENN(Tabelle1!A10:A30;A10;Tabelle1!B10:B30)/ZÄHLENWENN(Tabelle1!A10:A30;A10))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.
Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen. Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen. Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet. Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.
http://home.media-n.de/ziplies/

Bild


Betrifft: AW: Namen auslesen
von: mimi
Geschrieben am: 30.09.2003 16:37:55

Hallo Hajo,

das sieht ja wild aus mit den Formeln.... :-)

ich möchte dieses Makro verwenden:


Sub Namenfilter()
    Sheets("Auswertung").Range("B5").Select
    Selection.AutoFilter Field:=1, Criteria1:="Krause"
    Rows("2:2").Select
    Selection.Copy
    Sheets("Tabelle").Select
    Rows("3:3").Select
    Selection.PasteSpecial Paste:=xlValues, Operation:=xlNone, SkipBlanks:= _
        False, Transpose:=False
    Sheets("Auswertung").Select
    Selection.AutoFilter Field:=1
End Sub


Da, wo Krause steht, könne diverse Namen stehen, alle die in Spalte B6:B sind.
Das Makro muß also für ALLE NAMEN sein und jeder arf nur EINMAL das Makro durchlaufen!
Jetzt hab ich gar keine Zeit mit deine Antwort genau durchzulesen, daß muß leider bis Morgen von meiner Seite Zeit haben. Das oben ist dazu da, falls du mich nicht richtig verstanden hast.
Also bis morgen und schon mal 1000 Dank für deine Mühe
Michael


Bild


Betrifft: AW: Namen auslesen
von: Hajo_Zi
Geschrieben am: 30.09.2003 16:39:50

Hallo Michael

auf select, Activate usw. kann in VBA zu 99% verzichtet werden.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Namen auslesen
von: Mimi
Geschrieben am: 01.10.2003 08:22:36

Guten Morgen Hajo,

so da bin ich wieder und habe mir dein Lösungsvorschlag von gestern noch mal angeschaut!
Verstanden habe ich das leider überhaupt nicht! Ich weiß gar nicht, was die Formel macht-hilft die mir denn weiter bei meinem Makro?
Kann ich mir leider gar nicht vorstellen, weil ich feste Werte zu einem bestimmten
Zeitpunkt brauche, was mein makro mir liefern würde. Eine Formel kann das doch nicht.

Ich habe das mit der Formel auch gar nihct hinbekommen!
Habe Tabelle 1 mit "Test....gefüllt" und in Tabelle2 "a1" habe ich die Formel:
=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE(Tabelle1!A$1:A$100));Tabelle1!A$1:A$100)=1;ZEILE(Tabelle1!A$1:A$100));ZEILE())))
geschrieben. Da passiert aber rein gar nix - da hab ich bestimmt noch was falsch gemacht!


Zu deiner Aussage "select....." Ich hab schon gehört, dass das Zeit kostet, aber ich hatte damit noch keine Problem, außerdem bin ich ein "Makrorekorder-Benutzer". Ich bin gerade langsam dabei, mir das ganze genauer anzuschauen, hab mir sogar schon eim Buch gekauft, aber im Moment hab ich dafür keine Zeit.

Kannst du mir bitte bei dem Makro weiterhelfen und mir sagen,
wie mein Problem mit den "Namen" zu lösen ist?

Vielen Dank
Michael


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Namen auslesen"