Bedingte Anzahl

Bild

Betrifft: Bedingte Anzahl
von: gerhard
Geschrieben am: 30.09.2003 15:23:31

Hallo,

ich habe in Zeile 3 viele verschiedene Daten (Mehrzahl von Datum) stehen, aber es gibt auch Daten, welche mehrfach vorkommen.

Nun möchte ich die Anzahl errechnen. Die mehrfach vorkommenden sollen aber auch nur einmal gezählt werden.

Gibt es hierfür eine Funktion?

Danke Gerhard

Bild


Betrifft: AW: Bedingte Anzahl
von: mimi
Geschrieben am: 30.09.2003 15:31:39

eine Möglichkeit (nicht sehr elegant) wäre den Spezialfilter zu benutzen!
"Spezialfilter, Keine Duplikate klicken und dann Anzahl"

Gruß
Michael


Bild


Betrifft: AW: Bedingte Anzahl
von: Mac4
Geschrieben am: 30.09.2003 15:43:04

Hallo Gerhard,

folgende Matrixformel zählt die unterschiedlichen Einträge in A3:G3

{=SUMME(WENN(A3:G3="";0;1/ZÄHLENWENN(A3:G3;A3:G3)))}

Marc


Bild


Betrifft: AW: Bedingte Anzahl
von: gerhard
Geschrieben am: 30.09.2003 16:05:29

Danke Marc, klappt einwandfrei. Auch der Spezialfilter funktioniert, aber nicht so elegant.


Bild


Betrifft: Summe unterschiedlicher Einträge - bei Zahlen
von: Boris
Geschrieben am: 30.09.2003 17:09:45

Hi Gerhard,

in Ergänzung zu der Matrixlösung hier noch ne Array-freie Variante (funktioniert aber nur für Zahlen - aber Datümer sind ja solche):

=SUMME(N(HÄUFIGKEIT(A:A;A:A)>0))

Vorteil: Rechnet bei großen Bereichen wesentlich schneller. Zudem kann man die ganze Spalte (A:A) referenzieren.
Nachteil: Wie bereits erwähnt - funktioniert nur für Zahlen.

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Bedingte Anzahl"