Das Archiv des Excel-Forums

WENN-Funktion

Bild

Betrifft: WENN-Funktion
von: Julle

Geschrieben am: 01.10.2003 16:54:39

Bin das erste Mal hier, hoffe auf Antworten von euch zu folgendem Problem:

Senkrecht stehen in Spalte A Zahlen von -100 bis +100.

In Spalte B soll jeweils rechts bei Zahlen

größer als 1 der Text "stark steigend"
größer als 0 der Text "leicht steigend"
kleiner als 0 der Text "leicht fallend"
kleiner als -1 der Text "stark fallend"
gleich 0 der Text "unverändert"

ausgegeben werden.

Folgende Funktion hilft nur bis zu den Zahlen bis -1 alles tiefer wird mir immer als "leicht fallend" ausgegeben.

=WENN(A1>=1;"stark steigend";WENN(A1>0;"leicht steigend";WENN(A1<0;"leicht fallend";WENN(A1<=-1;"stark fallend";"unverändert"))))

Wäre euch um eine Antwort sehr dankbar, Julle.
Bild


Betrifft: AW: WENN-Funktion
von: Andreas Schindler
Geschrieben am: 01.10.2003 16:59:41

so müßte es klappen

=WENN(A1>=1;"stark steigend";WENN(A1>0;"leicht steigend";WENN(A1<=-1;"stark fallend";WENN(A1<0;"leicht fallend";"unverändert"))))

Gruß
Andreas


Bild


Betrifft: Danke Andreas!
von: Julle
Geschrieben am: 01.10.2003 17:05:39

Hat wunderbar funktioniert.

Schönen Abend, Julle.


Bild


Betrifft: AW: WENN-Funktion
von: Marc
Geschrieben am: 01.10.2003 17:01:10

Hallo julle,

kein Wunder, die Bedingung, ob A1<=-1 ist wird ja auch gar nicht abgefragt, weil eine Zahl < -1 ja auch automatisch < 0 ist.

Probier mal das:
=WENN(A1>=1;"stark steigend";WENN(A1>0;"leicht steigend";WENN(UND(A1<0;A1> -1);"leicht fallend";WENN(A1<=-1;"stark fallend";"unverändert"))))

Grüsse,
Marc


 Bild

Excel-Beispiele zum Thema " WENN-Funktion"

SUMMEWENN-Funktion über mehrere Tabellenblätter download Beispiele zum Einsatz der ZÄHLENWENN-Funktion download