Herbers Excel-Forum - das Archiv

Summen Formel Hilfe!!!!

Bild

Betrifft: Summen Formel Hilfe!!!!
von: Sven
Geschrieben am: 03.10.2003 17:32:22
Hallo Freak´s,
ich habe hier ein Tabellenblatt abgebildet, welches ich
auf einem anderen Tabellenblatt der gleichen Datei auswerten möchte.

Mit der unten beschriebenen Matrix Summenformel habe ich
leider Probleme!
Wer kann mir helfen???

Ausbuchungen
Spalte A B C D E F
Datum Monat Menge EK Gesamt EK plus/minus
04.01.2003 1 1 200 200 plus
05.01.2003 1 2 100 200 plus
05.02.2003 2 2 100 200 plus
06.02.2003 2 2 100 200 plus
07.02.2003 2 2 100 200 plus
08.02.2003 2 2 100 200 plus
09.02.2003 2 2 100 200 plus
10.02.2003 2 2 100 200 plus
11.02.2003 2 2 100 200 plus
12.02.2003 2 2 100 200 plus
13.02.2003 2 2 100 200 minus
30.03.2003 3 2 100 200 minus
15.02.2003 2 2 100 200 plus
16.02.2003 2 2 100 200 plus
17.02.2003 2 2 100 200 plus
18.02.2003 2 2 100 200 plus
19.02.2003 2 2 100 200 plus
20.02.2003 2 2 100 200 plus
21.02.2003 2 2 100 200 plus


Ergebnis aller Plusbuchungen im Monat 1
B25--> 0

Formel in Zelle B25 =SUMME((B3:B21="1")*(F3:F21="plus")*E3:E21)
mit Strg+Umschalt+Enter Matrix Formel erzeugt.

in Spalte B ist diese Formel--> =MONAT(Datum)

Warum Funktioniert die Formel nicht in Zelle B25 ???
Ich möchte auf einem anderen Tabellenblatt der gleichen Datei
eine Übersicht haben, wo nach Monaten sortiert die Gesamtsummen
sämtlicher Plusbuchungen in € pro Monat sowie sämtliche Minusbuchungen in € ausgewiesen werden.
Außerdem möchte ich die Anzahl der Plus und Minusbuchungen je Monat
ausweisen.--> Formel ??? =SUMME((B3:B21="1")*(J2:J20="plus"))
Matrix Formel!

P.S.
Arbeite das erste mal mit diesen Matrix Formeln...

Schöne Grüße und Vielen Dank

Sven

Bild

Betrifft: =Summenprodukt
von: Günther Oppold
Geschrieben am: 03.10.2003 17:41:53
Hi Sven,

zum ersten kannst Du versuchen die Monatsabfrage nicht mit "1" sondern ohne die Anführungszeichen zu machen, da es sich bei diesen Eingaben ja um Zahlen handelt.

2. ohne die ARRAY-Funktion (mit Strg+Umsch+Enter) kannst Du die Funktion Summenprodukt nehmen:
=SUMMENPRODUKT((B3:B21=1)*(F3:F21="plus")*E3:E21)

Günther
Bild

Betrifft: AW: Summen Formel Hilfe!!!!
von: Sebastian D.
Geschrieben am: 03.10.2003 17:46:35
Hi Sven,

die Formel MONAT() gibt eine Zahl zurück, keinen Text. Du mußt also Deine Formel so anpassen:
SUMME((B3:B21=1)*(J2:J20="plus"))

Beachte, daß "plus" natürlich ein Text ist und daher nach wie vor in Anführungszeichen stehen muss.

Grüße

Sebastian
Bild

Betrifft: AW: Summen Formel Hilfe!!!!
von: Sven
Geschrieben am: 03.10.2003 17:51:39
Vielen Vielen Dank!!!
für die schnelle kompetente Hilfe.
an
Günther Oppold
und Sebastian D.
Was zwei Anführungszeichen so bewirken können.....

Schöne Grüße

Sven aus Hamburg
 Bild
Excel-Beispiele zum Thema " Summen Formel Hilfe!!!!"
Summenbildung bei Checkboxaktivierung Summenformel unter Zahlenreihe eintragen
Summenbezüge korrigieren Zwischensummen eintragen
Summenformel per VBA eintragen Summen unter Berücksichtigung von Ober- und Untergrenzen
Summen zwischen zwei Zeiträumen ermitteln Zellen in Abhängigkeit des Summen-Teilergebnisses markieren
Nur Summenformel zur längsten Spalte eintragen Anzeigen von Werten und Formeln