Das Archiv des Excel-Forums

Wenn Formel

Bild

Betrifft: Wenn Formel
von: Timo

Geschrieben am: 08.10.2003 12:12:53

Hallo Excelfreunde,
eine Frage:
in e4 habe ein Wert (28)= Alter
Ich möchte wissen wie viele Urlaubstage zustehen:
bis zu vollendeten 30.Lebenjahr: 26 Urlaubstage
bis zu vollendeten 40.Lebenjahr: 29 Urlaubstage
nach vollendetem 40.Lebenjahr: 30 Urlaubstage
wie soll die Formel sein?

Danke Timo
Bild


Betrifft: =26+(e4>30)*3+(e4>40)
von: IngoG
Geschrieben am: 08.10.2003 12:17:13

Hallo Timo,
statt der wenn-abfrage tuts auch obige formel

Gruß ingo


Bild


Betrifft: AW: Wenn Formel
von: Bernd
Geschrieben am: 08.10.2003 12:23:06

Hallo Timo,

war es so gemeint?

Gruss Bernd
PS. Freue mich über Feedback

Tabelle1
 EF
43929 Urlaubstage
Formeln der Tabelle
F4 : =WENN(E4<=30;"26 Urlaubstage";WENN(E4<40;"29 Urlaubstage";WENN(E4>=40;"30 Urlaubstage";"")))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bild


Betrifft: AW: Wenn Formel
von: timo
Geschrieben am: 08.10.2003 12:37:31

Hallo Bernd und Ingo,
Beide Formel funkt. Danke.
.... was ist wenn e4 leer ist.
Mit eure Formel steht immer 30.
Ciao
Timo


Bild


Betrifft: AW: Wenn Formel
von: ingoG
Geschrieben am: 08.10.2003 12:48:18

HAllo Timo,

wenn e4 leer ist liefert meine Formel 26, wenn ein leerzeichen drinsteht, dann 30
wenn Du bei leerer zelle e4 ein leeres ergebnis haben möchtest kannst du die formel abändern in:

=WENN(E4="";"";26+(E4>30)*3+(E4>40))

wenn auch bei nur leerzeichen in e4 ein leeres ergebnis zurückgegeben werden soll funktioniert folgende formel:

=WENN(WECHSELN(E4;" ";"")="";"";26+(E4>30)*3+(E4>40))

Gruß Ingo

sollte so funzen


Bild


Betrifft: AW: Wenn Formel
von: Bernd
Geschrieben am: 08.10.2003 12:54:18

Hallo Timo,

dann so ...

Gruss Bernd

Tabelle1
 EF
40 
Formeln der Tabelle
F4 : =WENN(E4=0;"";WENN(E4<30;"26 Urlaubstage";WENN(E4<40;"29 Urlausbstage";WENN(E4>39;"30 Urlaubstage";""))))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bild


Betrifft: Danke Bernd, Danke Ingo o.T.
von: Timo
Geschrieben am: 08.10.2003 12:57:46

.


Bild


Betrifft: =ISTZAHL(E4)*((E4>0)*26+(E4>30)*3+(E4>40))
von: WF
Geschrieben am: 08.10.2003 13:19:20

Hi Timo,

denn, steht in E4 Text werden Tage ausgegeben.

Salut WF


http://www.excelformeln.de/
die ultimative Formelseite


Bild


Betrifft: doppelt.....siehe unten oT
von: IngoG
Geschrieben am: 08.10.2003 18:26:49

.


 Bild

Excel-Beispiele zum Thema " Wenn Formel"

Anzeigen von Werten und Formeln download Zeile einfügen und Formeln und Werte übernehmen download
Formeln mit Zelladressen speichern download Zeilenumbruch in Formel erzwingen download
Aktueller Arbeitsblattname in Formel download Variable in Formel einbauen download
Ein Zeichen in einer Formel suchen download Variable in Excel-Formel einbauen. download
Summenformel unter Zahlenreihe eintragen download Arbeitszeittabelle und SVERWEIS-Formel download
Zeilen mit leeren Formeln beim Druck unterdrücken download Ausgabe einer benutzerdefinierten Funktion in Matrixformel download
Listung der mit der Formel KOMBINATIONEN() ermittelten Elemente download Alle Formeln und Links in Werte wandeln download
Formel bis zur letzten Zeile der Nebenspalte kopieren download Summenformel per VBA eintragen download
Namen löschen ohne Formeln zu zerstören download Anzeige der Formel mit Quellblattangabe download
Alle Formeln und Zahlen löschen download Textstring in berechenbare Formel umwandeln download
Spielpaarungen von Vorrunde bis Finale durch Formeln ermitteln download Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download
Wahrheitsprüfung einer mit Zellwerten zusammengestzten Formel download SVERWEIS-Formel über mehrere Fundstellen download
Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download
Beispiel für die Anwendung der SUMMEWENN-FORMEL download Datei auswählen, öffnen und Formelsuchdialog anzeigen download
Formelbereich in Einzelelemente aufschlüsseln download Signal, wenn sich Formelwert über eine Grenze bewegt download
Formeleingabe über ShortCut download UserForm-Aufruf, wenn Formel-Wert Grenze überschreitet download
In Abhängigkeit von einem Formelwert Makro starten download In Abhängigkeit von einem Formelwert Mail mit Outlook versenden download
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download Sortierung mit Formel-Leerstrings am Ende download
Nach Formelkalkulation Zellwert erhöhen download Markierung von Formeln über bedingte Formatierung download
Zellschutz nur für Formeln download Text in Formel und Formel in Text download
Blatt ohne Code, Steuerelement und Formeln speichern download Zählen von in einer Formel vorkommenden Zahlen download
Temporärer VBA-Einsatz einer Matrixformel download Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download
Dynamischer Blattname in SVERWEIS-Formel download Bei Eintrag Übernahme der Formel aus Nebenzelle download
TextBox-Eingabe mit Formel weiterberechnen und zurückgeben download Formeltexte anzeigen download
Formel zur Ermittlung von Ostersonntag download Ermittlung von Datenbank- und Array-Formelergebnissen per VBA download