Das Archiv des Excel-Forums

Nummerierung von Teilergebnis-Sätzen

Bild

Betrifft: Nummerierung von Teilergebnis-Sätzen
von: Werner Lewers

Geschrieben am: 08.10.2003 16:11:45

Hallo Forum,
ich habe eine Tabelle mit einigen 100 Datensätzen, die in Spalte 1 durchnummeriert sind (A1 = 0, A2 = A1+1 etc).
Mit Einsatz von Filtern erhalte ich auch die gewünschte Auswahl von Zeilen. Es erscheint allerdings in Spalte 1 (= laufende Nummer) die Nummer der Zeile in der gesamten Tabelle.

Die Anzahl der gesamten bzw. auch ausgewählten Zeilen erhalte ich durch z.B. die Formel '=TEILERGEBNIS(3;A7:A404)'

Ist es möglich, die gefilterten Zeilen neu zu nummerieren, um z.B. auch eine Rangfolge zu erreichen??

Wäre für Hilfestellung dankbar.

M.f.G.
Werner
Bild


Betrifft: In gefilterter Tabelle durchnummerieren
von: Boris
Geschrieben am: 08.10.2003 16:24:50

Hi Werner,

Spalte A ist deine Nummernspalte. Nach Spalte B wird z.B. gefiltert.
In Zeile 1 die Überschriften.
Schreibe in A2 folgende Formel und kopier sie runter:
=WENN(B2="";"";TEILERGEBNIS(3;$B$1:B1))

Jetzt stimmt die Nummerierung auch in der gefilterten Tabelle.

Grüße Boris


Bild


Betrifft: AW: In gefilterter Tabelle durchnummerieren
von: Werner Lewers
Geschrieben am: 08.10.2003 16:44:15

Hi Boris,
vielen Dank - es funktioniert und ist OK, wenn man den Filter nur über eine Spalte setzt.

Bei mir stehen hintereinander (in einer Schülertabelle...)

--> lfd.Nr. - Name - Geschlecht (m/w) - Konfession - Staatsangehörigkeit

Ich möchte z.B. filtern

- nur Geschlecht = m
- Konfession = Islam
- Staatsangehörigkeit = Türkei

Geht das dann auf ähnliche Art und Weise??

Gruß
Werner


Bild


Betrifft: Alles kein Problem, solange...
von: Boris
Geschrieben am: 08.10.2003 18:03:49

Hi Werner,

...in diesem Fall in Spalte B auch alle Zellen gefüllt sind.
Wenn du natürlich nach Spalte E filterst, und somit in Spalte B im Filterergebnis auch leere Zellen vorkommen können, dann stimmt´s natürlich nicht mehr.
In diesem Fall verkette in einer Spalte RECHTS neben deiner Tabelle alle Werte aus allen Spalten mit =B2&C2&D2 und kopier das runter.
Dann nimmst du mit der gleichen Teilergebnisfunktion Bezug auf diese Hilfsspalte - dann wird es auch immer stimmen.

Grüße Boris


Bild


Betrifft: AW: Alles kein Problem, solange...
von: Werner Lewers
Geschrieben am: 08.10.2003 19:21:17

Hi Boris,

das genau war's. Hat mir sehr geholfen!!

Vielen Dank.
Ciao


 Bild