Das Archiv des Excel-Forums

Statistik

Bild

Betrifft: Statistik
von: Dieter

Geschrieben am: 08.10.2003 18:28:05

Hallo!

ich habe eine Zahlenkollone von 8, 25, 9, 15 ...
Jetzt möchte ich eine Summe erhalten die wie viele Zahlen sind von 1-20, 21-40,... unter Berücksichtigung eines weiteren Kriteriums!!!

Danke für eure Hilfe

lg
Dieter
Bild


Betrifft: AW: Statistik
von: Klaus-Dieter
Geschrieben am: 08.10.2003 18:34:43

Hallo Dieter,

kann man das weitere Kriterium auch erfahren? Oder ist das geheim?



Gruß Klaus-Dieter




Bild


Betrifft: AW: Statistik
von: Dieter
Geschrieben am: 08.10.2003 18:37:30

Hallo Klaus-Dieter,

nein das ist nicht geheim. Das Kriterium bedeutet Anfrage oder Bestellung - Hoffe natürlich auf so oft wie möglich Bestellung in der Liste steht...

lg
dieter


Bild


Betrifft: AW: Statistik
von: Reinhard
Geschrieben am: 08.10.2003 19:30:28

Hi Dieter,
Summenprodukt und Matrix ist mir noch ein Buch mit mehr als sieben Siegeln *gg*
Hauptsache es funktioniert erstmal, sicher geht es einfacher.
Gruß
Reinhard

A    B        C        D     E       F
betrag 	a/b		bereich	a/b	Anz
34	a		1-20	a	2
2	b		1-20	b	2
100	b		21-40	a	2
23	b		21-40	b	1
39	a		41-60	a	0
6	b		41-60	b	0
7	a		>60	a	0
6	a		>60	b	1
ergibt sich mit diesen Formeln in Spalte F
Anz
=SUMMENPRODUKT(($A$2:$A$9<=20)*($B$2:$B$9="a"))
=SUMMENPRODUKT(($A$2:$A$9<=20)*($B$2:$B$9="b"))
=SUMMENPRODUKT(($A$2:$A$9<=40)*($B$2:$B$9="a"))-SUMMENPRODUKT(($A$2:$A$9<=20)*($B$2:$B$9="a"))
=SUMMENPRODUKT(($A$2:$A$9<=40)*($B$2:$B$9="b"))-SUMMENPRODUKT(($A$2:$A$9<=20)*($B$2:$B$9="b"))
=SUMMENPRODUKT(($A$2:$A$9<=60)*($B$2:$B$9="a"))-SUMMENPRODUKT(($A$2:$A$9<=40)*($B$2:$B$9="a"))
=SUMMENPRODUKT(($A$2:$A$9<=60)*($B$2:$B$9="b"))-SUMMENPRODUKT(($A$2:$A$9<=40)*($B$2:$B$9="b"))
=SUMMENPRODUKT(($A$2:$A$9>60)*($B$2:$B$9="a"))
=SUMMENPRODUKT(($A$2:$A$9>60)*($B$2:$B$9="b"))



Bild


Betrifft: AW: Statistik
von: Hans W. Hofmann
Geschrieben am: 08.10.2003 20:22:17

Wenn ich Dich richtig verstanden habe, willst Du Deine Zahlenreihe in
bestimmten Intervallen auszählen, dann HÄUFIGKEIT


Gruß HW


Bild


Betrifft: AW: Statistik
von: Klaus-Dieter
Geschrieben am: 08.10.2003 21:21:34

Hallo Dieter,

hier meine Lösung per Makro:

Ausgangstabelle (Ausschnitt)
 AB
1AnzahlAnfrage/Bestellung
265B
312B
413B
585B
647A
7176A
87B
963B
1084A
11140A
12103A
1382A
1464B
15155A
16183B
1797B
Excel Tabellen einfach im Web darstellen
  Excel Jeanie HTML  2.0    Download  
Ergebnistabelle
 ABC
1BereichAB
20 - 2075
321 - 4025
441 - 6036
561 - 8037
681 - 10067
7101 - 12056
8121 - 14073
9141 - 16051
10161 - 18056
11181 - 20056
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Das Makro:
Sub zählen2()
Dim r As Integer
Dim s As Integer
Dim b As Integer
Dim az(200, 250) As Integer
Dim d As Integer
Dim t As Integer, tt As Integer
For r = 2 To Worksheets("Tabelle1").Range("A65536").End(xlUp).Row
Select Case Worksheets("Tabelle1").Cells(r, 1)
Case Is < 21
b = 1
Case Is < 41
b = 2
Case Is < 61
b = 3
Case Is < 81
b = 4
Case Is < 101
b = 5
Case Is < 121
b = 6
Case Is < 141
b = 7
Case Is < 161
b = 8
Case Is < 181
b = 9
Case Is < 201
b = 10
End Select
If Worksheets("Tabelle1").Cells(r, 2) = "A" Then
d = 1
Else: d = 2
End If
az(b, d) = az(b, d) + 1
Next r
For s = 1 To 10
For t = 1 To 2
Worksheets("Tabelle2").Cells(s + 1, 1 + t) = az(s, t)
Next t
Next s
End Sub


Code eingefügt mit: Excel Code Jeanie

Die fett geschriebenen Zellinhalte in der Ergebnistabelle sind von Hand eingefügt.


Gruß Klaus-Dieter




 Bild