Berechnung von Afa-Sätzen

Bild

Betrifft: Berechnung von Afa-Sätzen
von: Jürgen
Geschrieben am: 10.10.2003 11:00:14

Hallo Gemeinde,
Mein Problem ist folgendes:
Ich muss die jährliche Abschreibung (linear) von Anlagegütern ermitteln.
Bekannt ist Anschaffungsdatum, Anschaffungswert, Abschreibedauer.
Problem: Ist das Anschaffungsdatum später als der 30.06. eines Jahres kann im ersten Jahr nur die Hälfte der Jahres-Afa angerechnet werden.
Beispiel: Anschaffung eines LKW am 15.09.1999
Kosten 100.000 €
Afa-Dauer 4 Jahre -> Afa/Jahr = 25.000 €
Afa 1999 = 12.500 €
Afa 2000 - 2002 = 25.000 €/Jahr
Afa 2003 = 12.500 €
Wie kann ich aus den vorhandenen Daten in Excel die 12.500 € für das Jahr 2003 berechnen. Ich steh leider aufm Schlauch.

Besten Dank schonmal für Eure Hilfe
Gruß Jürgen


Bild


Betrifft: AW: Berechnung von Afa-Sätzen
von: Reinhard
Geschrieben am: 10.10.2003 11:40:17

Hi Jürgen,
lief im Test problemlos:
Gruß
Reinhard


datum 	wert	dauer	Jahr	afa
1.7.99	100000	4	1999	12500
			2000	25000
			2001	25000
			2002	25000
			2003	12500
ergibt sich mit folgenden Formeln:

Jahr
=JAHR(A2)
=WENN(E3<>"";D2+1;"")
=WENN(E4<>"";D3+1;"")
=WENN(E5<>"";D4+1;"")
=WENN(E6<>"";D5+1;"")
=WENN(E7<>"";D6+1;"")
=WENN(E8<>"";D7+1;"")
=WENN(E9<>"";D8+1;"")
=WENN(E10<>"";D9+1;"")
=WENN(E11<>"";D10+1;"")

afa
=WENN(WENN(A2>=DATWERT("01.07."&JAHR(A2));$B$2/$C$2/2;$B$2/$C$2)>0;WENN(A2>=DATWERT("01.07."&JAHR(A2));$B$2/$C$2/2;$B$2/$C$2);0)
=WENN(WENN($B$2-SUMME($E$2:E2)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E2))>0;WENN($B$2-SUMME($E$2:E2)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E2));"")
=WENN(WENN($B$2-SUMME($E$2:E3)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E3))>0;WENN($B$2-SUMME($E$2:E3)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E3));"")
=WENN(WENN($B$2-SUMME($E$2:E4)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E4))>0;WENN($B$2-SUMME($E$2:E4)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E4));"")
=WENN(WENN($B$2-SUMME($E$2:E5)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E5))>0;WENN($B$2-SUMME($E$2:E5)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E5));"")
=WENN(WENN($B$2-SUMME($E$2:E6)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E6))>0;WENN($B$2-SUMME($E$2:E6)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E6));"")
=WENN(WENN($B$2-SUMME($E$2:E7)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E7))>0;WENN($B$2-SUMME($E$2:E7)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E7));"")
=WENN(WENN($B$2-SUMME($E$2:E8)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E8))>0;WENN($B$2-SUMME($E$2:E8)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E8));"")
=WENN(WENN($B$2-SUMME($E$2:E9)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E9))>0;WENN($B$2-SUMME($E$2:E9)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E9));"")
=WENN(WENN($B$2-SUMME($E$2:E10)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E10))>0;WENN($B$2-SUMME($E$2:E10)>=$B$2/$C$2;$B$2/$C$2;$B$2-SUMME($E$2:E10));"")


Bild


Betrifft: AW: Berechnung von Afa-Sätzen
von: Jürgen
Geschrieben am: 10.10.2003 12:44:33

Hi Reinhard,
erst mal vielen Dank für Deine prompte Antwort. Funktioniert perfekt wie Du es in der Tabelle dargestellt hast.
Gibt nur ein Problem: Ich möchte nur immer die Afa für das das aktuelle Jahr berechnen
datum wert dauer Afa aktuelles Jahr (2003)
1.7.99 100.000 4 Jahre Ergebnis=12.500

Das aktuelle Jahr gebe ich an zentraler Stelle ein, sodass ich in der Anwendung im nächsten Jahr 2004 eingebe und dementsprechend Afa für 2004 = 0 ergeben soll.

Wäre super wenn Du dafür auch eine Lösung hättest
Nochmals vielen Dank
Gruß Jürgen


Bild


Betrifft: AW: Berechnung von Afa-Sätzen
von: Reinhard
Geschrieben am: 10.10.2003 15:28:42

Hi Jürgen,
ach, son Formelchen schreibt man sich einfach hin :-)
Gruß
Reinhard

    A      B      C      D       E 
1 datum   wert	dauer   Jahr  afa Jahr
2 3.3.99 100000   4     1999   25000
mit folgender Formel in E2:
=WENN(A2>=DATWERT("01.07."&JAHR(A2));WENN(ODER($D$2JAHR($A$2)+$C$2);0; _      
 WENN(ODER($D$2=JAHR($A$2);$D$2=JAHR($A$2)+$C$2);$B$2/$C$2/2;$B$2/$C$2)); _ 
 WENN(UND($D$2>=JAHR($A$2);$D$2<=JAHR($A$2)+$C$2-1);$B$2/$C$2;0))



Bild


Betrifft: Tsd Dank
von: Jürgen
Geschrieben am: 10.10.2003 15:38:42

Hi Reinhard,
wirklich tausend Dank. Leider reichen meine Kenntnisse offenbar (noch)nicht
für son Formelchen aus. Neid:-))

Nice Weekend
Gruß Jürgen



Bild


Betrifft: Thx for feedback o.w.T.
von: Reinhard
Geschrieben am: 10.10.2003 16:21:33

.


Bild


Betrifft: Leider zu früh gefreut:(
von: Jürgen
Geschrieben am: 13.10.2003 10:42:35

Hi Reinhard,
Leider erscheint die Meldung: die eingegebene Formel enthält einen Fehler...
Einen Fehler habe ich selbst gefunden: in der ersten Zeile $D$2JAHR($A$2) soll wahrscheinlich $D$2=JAHR($A$2)sein. Aber auch nach dieser Korrektur erscheint die Fehlermeldung und der Cursor plaziert sich auf der letzten 0.
Wäre mit dieser Formel auch abgesichert, dass bei Anschaffung vor 01.07. im 5. Jahr Afa=0 und bei Anschaffung nach 01.07. im 6. Jahr Afa=0 ergibt?
Letzte Frage: Wie lernt man am einfachsten die richtige Excel-Schreibweise für die Verschachtelung solcher Logik-Elemente?
Gruß Jürgen


Bild


Betrifft: sorry
von: Reinhard
Geschrieben am: 13.10.2003 16:39:01

Hi Jürgen,
keine Ahnung was da schief lief, irgendwie die falsche Formel kopiert, sorry.
ja, Werte größer 2003(wenn Kauf nach 1.7) oder größer 2002 (wenn kauf vor 1.7) oder kleiner 1999 ergeben 0.
Gruß
Reinhard

Ich weiss nicht wie das die Profis machen. ich hab auf einem Blatt die 4 Wenns aufgemalt als struktogrammSymbole,also beginnend mit

                              >1.7
                          J/        \N
                          /          \
                         /            \
                                   >=jahr(a2) AND <=(jahr(a2)+dauer)
                                        J/  \N
                                        /    \
                                     25000    0
(den J-Zweig hab ich jetzt mal weggelassen)

Dann exakt so angefangen einzugeben
also die Formelentwicklung sah dann so aus:
=WENN($A$2>=DATWERT("01.07."&JAHR($A$2);"JJJ";"NNN")
(dann den Neinzweig NNN eingefügt)
=WENN($A$2>=DATWERT("01.07."&JAHR($A$2);"JJJ";WENN(UND($D$2>=JAHR($A$2);$D$2<=JAHR($A$2)+$C$2-1);$B$2/$C$2;0))
(dann noch die beiden WENNS für den JJJ Zweig eingefügt usw.


=WENN($A$2>=DATWERT("01.07."&JAHR($A$2));WENN(ODER($D$2>JAHR($A$2)+$C$2;$D$2=JAHR($A$2);$D$2<=JAHR($A$2)+$C$2-1);$B$2/$C$2;0))


Bild


Betrifft: AW: Danke! Öffnen dauert ewig..
von: Jürgen
Geschrieben am: 14.10.2003 09:33:50

Hi Reinhard,
vielen Dank! Hab gestern nach langem probieren zwar auch noch aus deiner Formel eine funktionierende Lösung abgeleitet, aber die jetzige ist viel übersichtlicher und sogar für mich durchschaubar:)). Danke auch für die Beschreibung Deines Lösungsansatzes. Mal gucken ob ich mich damit leichter tue.
Noch zwei Fragen hätte ich:
1. Ich habe eine Excel-Datei gebastelt, die aufgrund sehr vieler SummeWennAbfragen in einer verknüpften Datei auf 1,5 MB angewachsen ist. Das Öffnen der Datei dauert mitlerweile 1 Min 15 Sek. In der Statusleiste steht dann Verknüpfungen. Ist das Normal und gibts da Möglichkeiten das zu optimieren?
2. In einer Datei mit Stammdaten habe ich zwei verschiedene Bereiche, die nach Eingabe neuer Daten oder Änderungen automatisch neu sortiert werden müssen. Ich habe eine Datei von Hajo Ziplies downgeloadet, die ein VBA-Skript enthält, aber leider nicht funktioniert. Hast Du eine Idee?
Wünsche einen schönen Tag mit viel Sonne!!
Grüße Jürgen


Bild


Betrifft: AW: Berechnung von Afa-Sätzen
von: Jürgen
Geschrieben am: 10.10.2003 12:25:03

Hi Reinhard,
erst mal vielen Dank für Deine prompte Antwort. Funktioniert perfekt wie Du es in der Tabelle dargestellt hast.
Gibt nur ein Problem: Ich möchte nur immer die Afa für das das aktuelle Jahr berechnen
datum wert dauer Afa aktuelles Jahr (2003)
1.7.99 100.000 4 Jahre Ergebnis=12.500

Das aktuelle Jahr gebe ich an zentraler Stelle ein, sodass ich in der Anwendung im nächsten Jahr 2004 eingebe und dementsprechend Afa für 2004 = 0 ergeben soll.

Wäre super wenn Du dafür auch eine Lösung hättest
Nochmals vielen Dank
Gruß Jürgen


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Berechnung von Afa-Sätzen"