Zählenwenn und Autofilter

Bild

Betrifft: Zählenwenn und Autofilter
von: Alex
Geschrieben am: 11.10.2003 22:02:59

Guten Abend liebe Leute !

Ich wende ich mich mit einer Frage an euch: Kann ich, wenn ich Daten mit dem Autofilter gefiltert habe, die Formel "Zählenwenn" auf diesen Bereich anwenden ? Mir ist nicht gelungen !!

Danke für eure Hilfe

Ciao Alex

Bild


Betrifft: AW: Zählenwenn und Autofilter
von: Hajo_Zi
Geschrieben am: 11.10.2003 22:05:39

Hallo Alex

reich vielleicht die Funktion Teilergebnis???



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Zählenwenn und Autofilter
von: Alex
Geschrieben am: 11.10.2003 22:17:12

Hallo Hajo !

Mit Teilergebnis kann ich ja nur mit Zahlen rechnen, oder ?? Ich muss aus einer Spalte eine Buchstabenkombination zählen, wobei jedoch aus der anderen Spalte Werte stehen durch die beim Autofiltern immer andere Mengen an Buchstabenkombinationen angezeigt werden. Dh. es sollte die Anzahl der Buchstabenkombination in jedem Fall (natürlich immer unterschiedlich viele) angezeigt werden.

Ciao Alex


Bild


Betrifft: AW: Zählenwenn und Autofilter
von: Klaus-Dieter
Geschrieben am: 11.10.2003 22:34:35

Hallo Alex,

sieh mal hier nach: Teilergebnis, da habe ich das genau beschrieben. (Geht auch mit Texten).


Gruß Klaus-Dieter




Bild


Betrifft: Zählen mit Bedingung in gefilterter Liste
von: Boris
Geschrieben am: 11.10.2003 23:29:03

Hi Alex,

das geht auch mit ner Formel.
Beispiel:
Gefiltert wird nach Spalte B. Jetzt möchtest du wissen, wieviele sichtbare Zellen in Spalte A das Wort "Alex" enthalten:

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(1:1000)))*(A1:A1000="Alex"))

Ist deine Liste länger als 1000 Zeilen, musst du das entsprechend anpassen.

Grüße Boris


Bild


Betrifft: AW: Zählen mit Bedingung in gefilterter Liste
von: Alex
Geschrieben am: 12.10.2003 10:16:12

Hallo Boris !

Danke vorerst für die Formel. Ich lege nochmals mein Problem dar: Ich filtere nach A. In B scheinen dann verschiedene Buchstaben (N,B etc.) in unterschiedlichen Mengen auf. Ich möchte jetzt wissen, wie viele N, B usw. in der Spalte ersichtlich sind. Wie kann ich das anstellen.

Ciao Alex


Bild


Betrifft: Zählen mit Bedingung in gefilterter Liste
von: Boris
Geschrieben am: 12.10.2003 21:32:01

Hi Alex,

wo ist das Problem? Das genau macht doch die Formel (die Spaltenangaben wirst du ja anpassen können).
Anscheinend hab ich es aber nicht ganz verstanden. Poste doch mal deinen Tabellenaufbau (kleines Beispiel).

Grüße Boris


Bild


Betrifft: AW: Zählen mit Bedingung in gefilterter Liste
von: Alex
Geschrieben am: 13.10.2003 23:01:38

Hello Boris !

Du hast recht, funktioniert tadellos, hatte nur eine kleine Bedienschwäche infolge trüben Auges. recht herzlichen Dank für deine Hilfe !

Alex


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Zählenwenn und Autofilter"