Das Archiv des Excel-Forums

Nach gleichen Einträgen suchen

Bild

Betrifft: Nach gleichen Einträgen suchen
von: walter

Geschrieben am: 13.10.2003 21:09:34

Hallo Excel-Profi´s

Ja, schon wieder DER, werdet Ihr wohl denken.
Folgendes Problem:in Spalte K10-K100 wird die Personal Nr.der Fahrer eingetragen
Um zu verhindern das ein Nr. mehrmals vorkommt, möchte ich, dass doppelte Einträge mit roten Hintergrund gefärbt werden, was mir auch mit Bedingter Formatierung so =WENN($K$18>0;(ODER($K$18=$K$19;$K$18=$K$20;$K$18=$K$21;$K$18=$K$22;$K$18=$K$23;$K$18=$K$24;$K$18=$K$25;$K$18=$K$26));"") gelungen ist.
Nur, ist das der richtige Weg ? Ziemlich mühsam mehr als 100 zellen so zu formatieren, oder gibts da noch einen viel schnelleren und eleganteren Weg.

Vielen Dank für Eure Mühe, walter
Bild


Betrifft: AW: Nach gleichen Einträgen suchen
von: Hajo_Zi
Geschrieben am: 13.10.2003 21:13:58

Hallo Walter

Tabelle3
 A
11
22
33
41
52
63
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =ZÄHLENWENN(A$1:A1;A2)>=1Abc
A31. / Formel ist =ZÄHLENWENN(A$1:A2;A3)>=1Abc
A41. / Formel ist =ZÄHLENWENN(A$1:A3;A4)>=1Abc
A51. / Formel ist =ZÄHLENWENN(A$1:A4;A5)>=1Abc
A61. / Formel ist =ZÄHLENWENN(A$1:A5;A6)>=1Abc
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/

Bild


Betrifft: AW: Nach gleichen Einträgen verhindern
von: Hajo_Zi
Geschrieben am: 13.10.2003 21:17:25

Hallo Walter

oder
kann man auch die Doppeleingabe selber verhindern:
z.B. unter Daten, Gültigkeit, benutzerdefiniert
Formel
=ZÄHLENWENN(A:A;A1)=1
nach unten kopieren.
Von Ulrich Schneider



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Nach gleichen Einträgen suchen
von: chris
Geschrieben am: 13.10.2003 21:16:14

Hallo Walter

geht einfacher

bereich k10 bis k100 markieren
format bedingte formatierung
Formel ist
=zählenwenn($k$10:$k$100;k10)>1

Gruß
Christian


Bild


Betrifft: AW: Danke Hajo_Zi, Danke chris
von: walter
Geschrieben am: 13.10.2003 21:45:19

Vielen Dank für Eure Hielfe, wieder bin ich einen Riesenschritt weitergekommen.
wünsche Euch noch einen schönen Abend, walter


 Bild

Excel-Beispiele zum Thema " Nach gleichen Einträgen suchen"

Zellen vergleichen und markieren download Tabellen vergleichen download
Spalten A und B vergleichen und Doppel in C listen download Werte vergleichen download
Bereiche auf Übereinstimmung vergleichen download Daten in jeweils einer Spalte zweier Tabellen vergleichen download
Werte vergleichen und Ergebnis in Tabelle eintragen download Tabellen vergleichen und Zeilen ersetzen download
Tabellen vergleichen und bei Nichtübereinstimmung markieren download Textdateien vergleichen und Unterschiede dokumentieren download
Spalte A mit B vergleichen und Doppel in C eintragen download Telefonnumern mit Liste vergleichen und durch Namen ersetzen download
Spalten mit gleichen Spaltenköpfen zusammenfassen download In UserForm-ListBox nur Datensätze gleichen Datums auswählen download
Werte vergleichen und übertragen download Teilstrings vergleichen und markieren download
Textmuster vergleichen download Zellinhalt suchen und Zelle auswählen download
Suchbegriff über mehrere Tabellenblätter suchen. download Suchen und weitersuchen download
Zahl +/- 1 suchen download Ein Zeichen in einer Formel suchen download
Datum suchen und Wert eintragen download Wert in Tabelle suchen und in UserForm ausgeben download
Letzte Zelle mit Inhalt suchen download Textdatei nach Begriff durchsuchen und Fundzeile importieren download
Wert in Array suchen, ohne jedes Datenfeld abzufragen download Wert in Tabellenblatt suchen und alle Fundwerte in zweite Tabelle download
Begriffe in ausgeblendeter Spalte suchen und Fundzeile markieren download Wert aus UserForm-TextBox in Tabelle suchen und in ListBox listen download
Suchbegriff aus einer UserForm-Textbox in Tabelle suchen und melden download Suchwert in zweiter Tabelle suchen und Fundzeile eintragen download
Suchen von Nachnamen in Zeichenfolgen download Dateien in einem Verzeichnis und Unterverzeichnissen suchen download
Datum suchen und Adresse der Fundzelle ausgeben download Begriffe in zweiter Tabelle suchen und Werte anfügen download
Text aus UserForm-TextBox in Tabelle suchen download Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen download
Suchbegriff in vorhergehenden Tabellen suchen download Werte aus UserForm-ComboBox suchen und Fundstelle kopieren download
Neueste Textdatei eines Verzeichnisses suchen und umbenennen download Artikelnummern suchen und jeweils letzte Fundstelle listen download
Wörter eines Satzes in Indizliste suchen download Wert aus UserForm-TextBox suchen und Fundstelle kopieren download
Zellwert nach Doppelklick in Tabelle suchen download Suchen in 2. Tabelle und Ersetzen der Quelldaten download
Wert in Tabelle 2 suchen und Fundstellen übertragen download Suchbegriff in Tabelle suchen und Fundzeilen auswählen download
Suchbegriffe aus Tabelle im Excel-WebArchiv suchen download Wert aus ComboBox in TextBox, dann in Tabelle suchen download
Artikelnummer über InputBox suchen und eintragen download Anwendung auf Fesplatte suchen download
Tabelle nach ComboBox-Auswahl durchsuchen download Werte suchen, eintragen und löschen download
Zeile 1 nach Wert der aktiven Zelle durchsuchen download Suchbegriff in Tabelle suchen und Fundzeilenindex zurückgeben download
Wert in zweiter Tabelle suchen und als Kommentar ausgeben download Wert in externer Mappe suchen und mit Format übernehmen. download
Artikelnummern nach Kriterien suchen und Datensätze kopieren download Wert in ComboBox einlesen, suchen, editieren, ausgeben download
Grafikdateien suchen download Suchen der Nachbarzelle der Zelle mit dem Maximalwert download
Text in Textdateien suchen und Fundzeilen in Tabelle ausgeben download Begriff suchen und Fundzeilen in anderes Blatt kopieren download
Zahl suchen und an den Fundstellen Zeile einfügen download Name und Vorname suchen, Werte und Fundstellen importieren download
Begriff in der ersten Spalte einer ListBox suchen download