nur jede. x. Zeile darstellen

Bild

Betrifft: nur jede. x. Zeile darstellen
von: Sandra
Geschrieben am: 24.10.2003 19:40:55

Habe eine Tabelle mit 2 Spalten und > 5000 Zeilen (Messwete) Möchte in 2 benachbarten Spalten nur jede 10/15/50 Zeile (untereinander) darstellen.

Bild


Betrifft: AW: nur jede. x. Zeile darstellen
von: PeterW
Geschrieben am: 24.10.2003 19:51:49

Hallo Sandra (eine Anrede macht sich immer gut),

etwas unklar ist die Aufgabenstellung schon: zwei benachbarte Spalten, Nachbarn von welchen Spalten; jede 10/15/50 Zeilen also die Zeilen 10, 15, 20, 30, 40, 45, 50... und bezogen auf die Zeilennummer oder falls nicht ab welcher Zeilennummer beginennd?

Gruß (auch die Zeit muss sein)
Peter


Bild


Betrifft: AW: nur jede. x. Zeile darstellen
von: Sandra
Geschrieben am: 24.10.2003 20:02:09

Hallo Peter,

erst einmal Entschuldigung für meine etwas unfeundliche und unverständliche Anfrage.

Ich habe ab Zeile 10 (bis Zeile >5000) in den Spalten A bzw. B Messwerte. Möchte nun in den Spalten E und F nur jede x. Zeile darstellen. Am liebsten würde ich mir x in einer beliebigen Zelle vorgeben. Die Spalten A und B würde ich dann löschen, um die Datei nicht zu groß werden zu lassen.

Vielen Dank schon einmal im voraus und ein schönes Wochenende!

Gruss
Sandar


Bild


Betrifft: AW: nur jede. x. Zeile darstellen
von: PeterW
Geschrieben am: 24.10.2003 20:21:54

Hallo Sandra,

wenn eine Makrolösung möglich ist wäre das (für mich) am einfachsten. Folgenden Code in ein Modul kopieren und per Schaltfläche oder über Extra - Makros - Ausführen starten. Der variable Wert für x muss in F6 stehen.

Sub Jede_X()
   Dim lgRow As Long
   Dim lgZiel As Long
   Dim intX As Integer
   intX = Range("F6")
   lgRow = 10 + intX
   lgZiel = 10
   Do Until IsEmpty(Cells(lgRow, 1))
      Cells(lgZiel, 5) = Cells(lgRow, 1)
      Cells(lgZiel, 6) = Cells(lgRow, 2)
      lgRow = lgRow + intX
      lgZiel = lgZiel + 1
   Loop
End Sub

Gruß
Peter


Bild


Betrifft: Vielen Dank!
von: Sandar
Geschrieben am: 24.10.2003 20:57:43

Schönes Wochenende!


Bild


Betrifft: AW: nur jede. x. Zeile darstellen
von: Hajo_Zi
Geschrieben am: 24.10.2003 20:25:40

Hallo Sandra

hier mal eine Formellösung

Tabelle9
 ABCDE
1110115115Angezeite Zeile
221023013015
3310345145 
4410460160 
5510575175 
6610690190 
77107105205 
88108120220 
99109135235 
1010110150250 
1111111165265 
1212112180280 
Formeln der Tabelle
C1 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D1 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C2 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D2 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C3 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D3 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C4 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D4 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C5 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D5 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C6 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D6 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C7 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D7 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C8 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D8 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C9 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D9 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C10 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D10 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C11 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D11 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
C12 : =INDIREKT("A" & (ZEILE()-1)*$E$2+$E$2)
D12 : =INDIREKT("B" & (ZEILE()-1)*$E$2+$E$2)
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

">

Bild


Betrifft: AW: nur jede. x. Zeile darstellen

von: FP
Geschrieben am: 24.10.2003 20:47:37

Hallo Sandra,

noch eine Formellösung: in G1 die gewünschte Zahl x eingeben

Excel Jeanie HTML
Formeln der Tabelle
E1 : =INDIREKT("A"&G$1*ZEILE())
F1 : =WENN(E1;SVERWEIS(E1;A:B;2;FALSCH);"")
E2 : =INDIREKT("A"&G$1*ZEILE())
F2 : =WENN(E2;SVERWEIS(E2;A:B;2;FALSCH);"")
E3 : =INDIREKT("A"&G$1*ZEILE())
F3 : =WENN(E3;SVERWEIS(E3;A:B;2;FALSCH);"")
E4 : =INDIREKT("A"&G$1*ZEILE())
F4 : =WENN(E4;SVERWEIS(E4;A:B;2;FALSCH);"")
E5 : =INDIREKT("A"&G$1*ZEILE())
F5 : =WENN(E5;SVERWEIS(E5;A:B;2;FALSCH);"")
E6 : =INDIREKT("A"&G$1*ZEILE())
F6 : =WENN(E6;SVERWEIS(E6;A:B;2;FALSCH);"")
E7 : =INDIREKT("A"&G$1*ZEILE())
F7 : =WENN(E7;SVERWEIS(E7;A:B;2;FALSCH);"")
E8 : =INDIREKT("A"&G$1*ZEILE())
F8 : =WENN(E8;SVERWEIS(E8;A:B;2;FALSCH);"")
E9 : =INDIREKT("A"&G$1*ZEILE())
F9 : =WENN(E9;SVERWEIS(E9;A:B;2;FALSCH);"")
E10 : =INDIREKT("A"&G$1*ZEILE())
F10 : =WENN(E10;SVERWEIS(E10;A:B;2;FALSCH);"")
E11 : =INDIREKT("A"&G$1*ZEILE())
F11 : =WENN(E11;SVERWEIS(E11;A:B;2;FALSCH);"")
E12 : =INDIREKT("A"&G$1*ZEILE())
F12 : =WENN(E12;SVERWEIS(E12;A:B;2;FALSCH);"")
E13 : =INDIREKT("A"&G$1*ZEILE())
F13 : =WENN(E13;SVERWEIS(E13;A:B;2;FALSCH);"")
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   ABER NICHT VERGESSEN: vor dem Löschen der Quelldaten - Formeln in Werte umwandeln! Servus aus dem Salzkammergut Franz

Bild


Betrifft: AW: nur jede. x. Zeile darstellen
von: FP
Geschrieben am: 24.10.2003 20:58:21

Hallo Sandra,

nimm diese Formeln ( entspricht Lösung von HaJo - aber kürzer ;-) )

Excel Jeanie HTML
Formeln der Tabelle
E1 : =INDIREKT("A"&G$1*ZEILE())
F1 : =INDIREKT("B"&G$1*ZEILE())
E2 : =INDIREKT("A"&G$1*ZEILE())
F2 : =INDIREKT("B"&G$1*ZEILE())
E3 : =INDIREKT("A"&G$1*ZEILE())
F3 : =INDIREKT("B"&G$1*ZEILE())
E4 : =INDIREKT("A"&G$1*ZEILE())
F4 : =INDIREKT("B"&G$1*ZEILE())
E5 : =INDIREKT("A"&G$1*ZEILE())
F5 : =INDIREKT("B"&G$1*ZEILE())
E6 : =INDIREKT("A"&G$1*ZEILE())
F6 : =INDIREKT("B"&G$1*ZEILE())
E7 : =INDIREKT("A"&G$1*ZEILE())
F7 : =INDIREKT("B"&G$1*ZEILE())
E8 : =INDIREKT("A"&G$1*ZEILE())
F8 : =INDIREKT("B"&G$1*ZEILE())
E9 : =INDIREKT("A"&G$1*ZEILE())
F9 : =INDIREKT("B"&G$1*ZEILE())
E10 : =INDIREKT("A"&G$1*ZEILE())
F10 : =INDIREKT("B"&G$1*ZEILE())
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Servus aus dem Salzkammergut Franz

 Bild

Beiträge aus den Excel-Beispielen zum Thema " nur jede. x. Zeile darstellen"