Fingerübung.....

Bild

Betrifft: Fingerübung.....
von: Jennifer
Geschrieben am: 27.10.2003 15:10:23

Hallo,

in einer Tabelle (n Zeilen, m Spalten) stehen 0en und 1en.
ich möchte gerne die Anzahl der Zeilen bestimmen, die mindestens eine 1 beinhalten. (Die Anzahl der Zeilen ist sehr groß und noch nicht bestimmt.)

Kann mir jemand weiterhelfen? Brauch ich da Visual Basic zu, wäre das einfacher?

Dürfte für die Profis eine Fingerübung sein, aber für mich ein größeres Problem.

Lieben Gruß

Jen

Bild


Betrifft: Zählenwenn()
von: Harald Kapp
Geschrieben am: 27.10.2003 15:16:25

Hallo Jennifer,
alles weitere siehe Excel-Hilfe.

Gruß Harald


Bild


Betrifft: AW: Fingerübung.....
von: Mac4
Geschrieben am: 27.10.2003 15:18:18

Hallo Jennifer,

SUMME(ZÄHLENWENN(A1:C100;">0"))

Marc


Bild


Betrifft: ZEILEN - nicht ZELLEN...;-)
von: Boris
Geschrieben am: 27.10.2003 15:22:46

Hi Marc, hi Jennifer,

...so steht es zumindest in der Frage. Daher ohne Hilfsspalte so:

=SUMMENPRODUKT(N(ZÄHLENWENN(INDIREKT("A"&ZEILE(1:1000)&":IV"&ZEILE(1:1000));1)>0))

Achtung auf Zirkelbezug! Diese Formel darf z.B. NICHT im Bereich A1:IV1000 stehen.

Grüße Boris


Bild


Betrifft: AW: ZEILEN - nicht ZELLEN...;-)
von: Jennifer
Geschrieben am: 27.10.2003 22:44:59

Hallo Boris,

vielen herzlichen Dank!

Ich hab bis grade eben versucht, die Funktionsweise der Formel nachzuvollziehen, leider vergeblich: Kannst du mir sagen, wie insbesondere SUMMENPRODUKT funktioniert? Ich sehe nicht ganz, wie die Matrixmultiplikation läuft (also lineare Algebra ist mir schon geläufig, nur eben nicht wie die Excelfunktion gerade bei diesem Problem funktioniert)

Jetzt hab ich deine und Ingos Formel eingebaut und würde sie auch gerne für mein ganzes Sheet benutzen: Ich bräuchte statt der Prüfung auf "mindestens eine 1" die Prüfung auf "mindestens einmal KEINE NULL" (sprich: auch das ein- oder mehrmalige Vorkommen von Zahlen ungleich Null oder Text würde dem Kriterium einer zu wertenden Zeile genügen).

Ich habe ewig gesucht, aber keinen Weg gefunden, dies umzusetzen, hast du da evtl. einen Tip für mich?

Lieben Gruß

Jen


Bild


Betrifft: AW: Fingerübung.....
von: Martin Halberstadt
Geschrieben am: 27.10.2003 15:18:32

Hallo Jen,

ich hoffe ich habe Dein Problem richtig verstanden.

Probier es mal mit folgender Formel:

=ZÄHLENWENN(A1:A1000;1)

Den Bereich der Formel musst Du selbstverständlich an Deine Datei anpassen.
Da Du den Bereich noch nicht genau weißt, kannst Du ja bsp.weise M:N nehmen.
So wird in den ganzen Spalten gezählt.

Lieben Gruß zurück,
Martin


Bild


Betrifft: AW: Fingerübung.....
von: ChrisL
Geschrieben am: 27.10.2003 15:20:56

Hi Jen

ZÄHLENWENN ist sicher der richtige Ansatz. Habe das Problem allerdings leicht anders aufgefasst und im Anhang findest du eine Lösung mit Hilfsspalte...

https://www.herber.de/bbs/user/1624.xls

Gruss
Chris


Bild


Betrifft: AW: Fingerübung.....
von: IngoG
Geschrieben am: 27.10.2003 16:10:14

Hallo Jennifer,

also angenommen, deine Matrix beginnt in $a$2 und in b1 steht die anzahl deiner Zeilen und in $c$1 steht die anzzahl deiner spalten

DAnn gibt dir die Formel

=SUMMENPRODUKT((ZÄHLENWENN(BEREICH.VERSCHIEBEN($A$1;ZEILE(INDIREKT("1:"&$B$1));0;1;$C$1);1)>0)*1)

die anzahl der zeilen in deiner Matrix zurück in denen mindestens eine 1 steht

Ich hoffe, das bringt dich weiter

Gruß Ingo


Bild


Betrifft: AW: Fingerübung.....
von: Jennifer
Geschrieben am: 27.10.2003 22:46:18

Hallo Ingo,

vielen herzlichen Dank! Deine Funktion läuft klasse!

Ich hab bis grade eben versucht, die Funktionsweise der Formel nachzuvollziehen, leider vergeblich: Kannst du mir sagen, wie insbesondere SUMMENPRODUKT funktioniert? Ich sehe nicht ganz, wie die Matrixmultiplikation läuft (also lineare Algebra ist mir schon geläufig, nur eben nicht wie die Excelfunktion gerade bei diesem Problem funktioniert)

Jetzt hab ich deine und Boris' Formel eingebaut und würde sie auch gerne für mein ganzes Sheet benutzen: Ich bräuchte statt der Prüfung auf "mindestens eine 1" die Prüfung auf "mindestens einmal KEINE NULL" (sprich: auch das ein- oder mehrmalige Vorkommen von Zahlen ungleich Null oder Text würde dem Kriterium einer zu wertenden Zeile genügen).

Ich habe ewig gesucht, aber keinen Weg gefunden, dies umzusetzen, hast du da evtl. einen Tip für mich?

Lieben Gruß

Jen


Bild


Betrifft: zeilen mit zahl < > 0
von: IngoG
Geschrieben am: 28.10.2003 00:03:27

Hallo Jennifer,
Ich glaube, hier funzt die Formel:

=SUMMENPRODUKT((ZÄHLENWENN(BEREICH.VERSCHIEBEN($A$1;ZEILE(INDIREKT("1:"&$B$1));0;1;$C$1);">0")+ZÄHLENWENN(BEREICH.VERSCHIEBEN($A$1;ZEILE(INDIREKT("1:"&$B$1));0;1;$C$1);"<0")>0)*1)

im einzelnen arbeitet die formel folgendermassen:
die funk summenprodukt arbeitet in einer Matrix nacheinander die einzelnen Bereiche ab
hier wird durch eine Kombination mit bereich.verschieben,zeile und indirekt erreicht,
dass nacheinander alle zeilen von 2 bis $b$1+1 durchsucht werden und in jeder zeile ein bereich von der ersten spalte bis zur $c$1'en spalte mit zählenwenn geprüft wird.
(Schlüssel ist hier die äußerst vielseitige Funktion: bereich.verschieben)

bei der obigen formel werden also alle zeilen der angegebenen Matrix gescannt, ob in ihnen entweder ein wert < 0 oder > 0 vorkommt und die gesamtzahl dieser Zeilen berechnet.

Im detail solltest Du dir die arbeitsweise der 5 verwendeten Funktionen einmal in der Hilfe anschauen.

Ich hoffe, das hilft Dir einigermassen weiter

Gruß Ingo



Bild


Betrifft: AW: Fingerübung.....
von: Jennifer
Geschrieben am: 27.10.2003 22:50:26

Vielen lieben Dank euch allen!

Ich wünsche Euch einen schönen Abend!

Viele Grüße

Jen


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Tabellenblatt durch Zell-Doppelklick auswählen "