Formel erweitern

Bild

Betrifft: Formel erweitern
von: Peter
Geschrieben am: 29.10.2003 13:18:34

Hallo Excels,
wer kann mir bei der erweiterung der folgenden Formel helfen.
=WENN(ZÄHLENWENN([ZählerlagergasV28.01.03.xls]l35!$B:$B;A3)=0;"";(ZÄHLENWENN([ZählerlagergasV28.01.03.xls]l35!$B:$B;A3)))
Diese Formel zählt also beim auffinden des Suchbegriffes(A3)die Menge.
Die Formel soll nun so erweitert werden, dass nur die gezählt werden wo gleichzeitig in [ZählerlagergasV28.01.03.xls]l35!$G:$G eine 95 steht.

Danke schon mal
Gruss
Peter

Bild


Betrifft: AW: Formel Summenprodukt
von: Jörg Gradert
Geschrieben am: 30.10.2003 03:13:16

Hallo Peter,
versuch es mal so

=WENN(SUMMENPRODUKT(([ZählerlagergasV28.01.03.xls]l35!$B1:$B1000=A3)*( [ZählerlagergasV28.01.03.xls]l35!$G1:$G1000=95))=0;"";SUMMENPRODUKT(([ZählerlagergasV28.01.03.xls]l35!$B1:$B1000=A3)*( [ZählerlagergasV28.01.03.xls]l35!$G1:$G1000=95)))

SUMMENPRODUKT() arbeitet nicht mit kompletten Spalten ($B:$B oder $G:$G geht nicht),ich habe darum erstmal 1000 Zeilen voreingestellt ($B1:$B1000 bzw. $G1:$G1000), falls Du in ZählerlagergasV28.01.03.xls mehr Einträge hast, musst Du die Obergrenzen anpassen, es funktioniert bis zur vorletzten Zeile.

Die Formel ist von Jürgen Recker

http://www.excelformeln.de/formeln.html?welcher=273

Gruss Jörg


Bild


Betrifft: AW: Formel Summenprodukt
von: Peter
Geschrieben am: 30.10.2003 07:55:54

Hallo Jörj,
vielen Dank für deine Hilfe.
Geht Ihr Vollexperten überhaupt nicht ins Bett?
Gruss
Peter


Bild


Betrifft: Danke für die Rückmeldung
von: Jörg Gradert
Geschrieben am: 30.10.2003 08:27:42

Hallo Peter,
da ich in der Nachtschicht arbeite, habe ich auch an meinen freien Tagen einen etwas anderen Rhytmus.

Gruss Jörg


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Formel erweitern"