Wenn-Funktion

Bild

Betrifft: Wenn-Funktion
von: Christian
Geschrieben am: 29.10.2003 13:27:15

https://www.herber.de/bbs/user/1657.xls

Hallo zusammen,

ich wäre dankbar für jede Hilfe, schaut euch doch bitte meine Tabelle an. Meine Probleme habe ich als Komentar hinterlegt!

Vielen Dank im voraus und einen schönen Tag noch!

Christian

Bild


Betrifft: AW: Wenn-Funktion
von: Martin Halberstadt
Geschrieben am: 29.10.2003 13:58:14

Hallo Christian,

ich hoffe ich kann Dir hiermit weiterhelfen:

1. fürs Geburtsdatum:
in H10 --> =WENN(J9="";"";DATEDIF(J9;HEUTE();"y"))

2. für "ZW":
in C15 --> =WENN(B15="";"";TAGE360(A16;B16+1))

3. für Betragsermittlung:
in F15 --> =WENN(UND(DATUM<01.07.03;H15<6);111;+WENN(UND(DATUM>01.07.03;H15<6);122;+WENN(UND(DATUM<01.07.03;H15>6);151;+WENN(UND(DATUM>01.07.03;H15>6);164;""))))

zur Erklärung: die Variable "DATUM" habe ich so benannt. Vielleicht musst Du pro Zeile eine weitere Zelle einfügen mit Daten, auf die Du die Formel dann beziehen kannst.

Falls Du weitere Fragen hast, kontaktier mich einfach.

Gruß,
Martin


Bild


Betrifft: Tipfehler meinerseits!!!
von: Martin Halberstadt
Geschrieben am: 29.10.2003 14:07:20

Hallo Christian,

hab nen Tipfehler eingebaut.

2. für "ZW":
in C15 --> =WENN(B15="";"";TAGE360(A16;B16+1))

Der obige Ausschnitt ist falsch. Es muss hinten natürlich TAGE360(A15;B15+1)) heißen.
Hab ich wohl zu schnell getippt.

Gruß, Martin

P.S.: Mach ma bitte Rückmeldung, falls es klappt. Hab das mehr oder weniger theoretisch gemacht.


Bild


Betrifft: AW: Tipfehler meinerseits!!!
von: Christian
Geschrieben am: 29.10.2003 14:52:42

Hallo Martin

Nach Berichtigung bekomme nun unter "ZW" ein leeres Feld. Ist aber mein Fehler, ich wollte
eigentlich den Wert "0"!


Bild


Betrifft: Schau mal hier!!!
von: Martin Halberstadt
Geschrieben am: 29.10.2003 15:13:24

Hey Christian,

ich habe Deine Datei mal ein wenig umgebaut, jetzt kannst Du sehen, wie es vielleicht sein sollte. Bitte beachte auch die gelben Felder. Das meinte ich nämlich damit, dass Du "Datum" und "01.07.03" nur als eine Art Platzhalter sehen sollst.

Wenn Du nun oben (J9) das Geburtsdatum änderst, dann kannst Du auch die korrekte Änderung in der Betragsermittlung sehen.

Falls Du die Formel, gesetz den Fall sie gefällt Dir überhaupt, später nach unten ziehen willst, vergiß nicht die Dollars für einen festen Bezug einzufügen.

Hier ist Deine Datei:
https://www.herber.de/bbs/user/1658.xls

Falls Du noch Fragen hast, melde Dich.
Und falls es klappt, bitte ich um eine kurze Rückmeldung.

Gruß,
Martin


Bild


Betrifft: AW: Schau mal hier!!!
von: Christian
Geschrieben am: 29.10.2003 16:56:12

https://www.herber.de/bbs/user/1659.xls


Hallo Martin,

vielen Dank für die guten Ansätze, hab meine Tabelle entsprechend angepasst, wäre nett, wenn
Du nochmals reinschauen könntest.

Jetzt nur noch das Problem mit der Ausgabe der Summe in der Zelle G25 (#Zahl!)
Dieses Tabellenblatt wird unter dem Namen der Person gespeichert und muss immer wieder
aktualisiert werden. D.h. die derzeit leeren Zeilen sollen für spätere Eintragungen bestehen
bleiben.

Ich hoffe ich hab mich verständlich ausgedrückt

Danke

Christian


Bild


Betrifft: AW: Schau mal hier!!!
von: Jörg Gradert
Geschrieben am: 29.10.2003 18:22:12

Hallo Christian,
geht es so?

https://www.herber.de/bbs/user/1660.xls

Gruss Jörg


Bild


Betrifft: AW: Schau mal hier!!!
von: Christian
Geschrieben am: 30.10.2003 09:23:21

Hallo Jörg,

vielen Dank, nach ein paar kleinen Veränderungen klappt es prima!

Schönen Tag noch

Christian


Bild


Betrifft: AW: Wenn-Funktion
von: Christian
Geschrieben am: 29.10.2003 14:40:40

Hallo Martin,

danke für Deine Mühe aber leider funktioniert es mit den genannten Formeln nicht:
-beim Geburtstag und bei "ZW" bekomm ich nur noch #### angezeigt

-nach Eingabe deiner Formel für die Betragsberechnung kommt die Anzeige für Formelfehler, markiert ist 01.07.03

Vielleicht hast du noch einen Tip

Vielen Dank

Christian


Bild


Betrifft: AW: Wenn-Funktion
von: Martin Halberstadt
Geschrieben am: 29.10.2003 14:59:27

Hallo Christian,

also die ersten beiden Formeln, wenn man meine nachgefügte kleine Korrektur mit einbezieht, funktionieren bei mir ohne Probleme.

Zu der Betragsberechnung: das (Datum<01.07.03) ist nur sinnbildlich gemeint. Du musst hier natürlich Zellen mit einbeziehen.

Also bei mir funktionieren mittlerweile alle drei Formeln. Das "DATUM" und "01.07.03" sind nur Platzhalter.

Gruß,
Martin


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Wenn-Funktion"