Mehrfacher Sverweis?

Bild

Betrifft: Mehrfacher Sverweis?
von: Stephan
Geschrieben am: 13.11.2003 13:26:15

Hallo Leute,
kann man auch einen mehrfachen Sverweis in einer Formel machen, so nach dem Motto, "guck ob 2 Kriterien erfüllt sind, dann mach das und das"?
Habe z.B. eine Tabelle mit Versandkosten, eingeteilt in <100km, <200km und <300km. Dabei soll aber auch auf das Gewicht abgestellt werden, <100kg, <200kg und <300kg. Die Entfernungen stehen in Spalte A, hier geht ja dann der SVerweis, den krieg ich ja auch hin. Das Gewicht steht in Zeile 1, dann geht ja nur der WVerweis. Aber die Kombination krieg ich einfach nicht hin!

Wer kann mir helfen?

Danke, Stephan

Bild


Betrifft: AW: Beispiel? Spalten?
von: Galenzo
Geschrieben am: 13.11.2003 13:47:15

Hallo,
ich hätte eine Lösung über MAtrixformel.
Hast du eine Beispielstabelle oder kannst du wenigstens mal beschreiben, welche Spalten, Überschriften , Beispielswerte du hast?

bis dann


Bild


Betrifft: AW: Beispiel? Spalten?
von: Holger Levetzow
Geschrieben am: 13.11.2003 13:52:11

du kannst den 3. Parameter doch nutzen als Spaltennummer, z.B.

=sverweis(X1;A1:E100;ganzzahl(gewicht/100)+1)

Holger


Bild


Betrifft: AW: Beispiel? Spalten?
von: Stephan
Geschrieben am: 13.11.2003 13:56:04

Hallo, habs mittlerweile selber rausgefunden. So gings: In A2-A5 stehen die km (100, 200, 250, 300), in B2-D2 das Gewicht (100, 200, 300). Dann hab ich die Formel genommen, und er zeigt mir den Wert an, der im Kreuz von km und kg steht:
=INDEX(A1:D5;VERGLEICH(A7;A1:A5;0);VERGLEICH(A8;A1:D1).

Hab aber noch ne Frage dazu: Ich gehe hier von festen Gewichten aus (100kg, 200kg usw.). Jetzt will ich aber die o.g. Formel so modifizieren, das es auch bei <100, <200 usw. geht. D.h. ich will die km eingeben und die kg (z.b. 79kg) und Excel sucht mir den Wert <100 raus usw.
Hoffe das ist einigermaßen verständlich.


Bild


Betrifft: Antwort und Frage
von: Dirk
Geschrieben am: 13.11.2003 13:52:53

Hallo.

Das is mir auch noch nich passiert. Hab ein bissel rumprobiert und es scheint zu funktionieren. Warum, sollen andere klären.

=SVERWEIS(A7;A1:E4;WVERWEIS(B7;A1:E4;2)-1)

In A7 steht die Entfernung, in B7 das Gewicht.

Cheers


Bild


Betrifft: Antwort und Frage
von: Dirk
Geschrieben am: 13.11.2003 13:56:13

Hallo.

Das is mir auch noch nich passiert. Hab ein bissel rumprobiert und es scheint zu funktionieren. Warum, sollen andere klären.

=SVERWEIS(A7;A1:E4;WVERWEIS(B7;A1:E4;2)-1)

In A7 steht die Entfernung, in B7 das Gewicht.

Cheers


Bild

Beiträge aus den Excel-Beispielen zum Thema " Mehrfacher Sverweis?"