Ziffern zählen

Bild

Betrifft: Ziffern zählen
von: Thorsten
Geschrieben am: 24.11.2003 14:10:40

Hallo,

ich habe eine Spalte mit einer Liste von Geldbeträgen. Ich möchte jetzt zählen lassen, wie oft die erste Nachkommastelle eine 0, 1, 2, 3, ... 8 und 9 ist.

Gibt es dafür eine Formel, oder wie könnte man dieses Problem am besten lösen?


Danke
Thorsten

Bild


Betrifft: AW: Ziffern zählen
von: IngoG
Geschrieben am: 24.11.2003 14:19:54

HAllo Thorsten,

in a1:a100 stehen deine Zahlen, in C1 die Ziffer (zB 0) dann funzt folgende Formel:

=SUMMENPRODUKT((GANZZAHL(REST($A$1:$A$100;1)*10)=C1)*($A$1:$A$100<>""))

Gruß Ingo

PS, eine Rückmeldung wäre nett...


Bild


Betrifft: AW: Ziffern zählen
von: Thorsten
Geschrieben am: 24.11.2003 14:33:40

Hallo,

vielen Dank für die Formel. Ich habe sie gleich in folgende Datei eingebaut:
https://www.herber.de/bbs/user/2130.xls

Ich glaube allerdings, es gibt ein Problem:
Wenn ich in Zelle A3 den Wert 12,10 eingebe müssten in C2 eine ZWEI erscheinen.

Ist da noch ein Fehler drin?


Thorsten


Bild


Betrifft: Rechengenauigkeit
von: IngoG
Geschrieben am: 24.11.2003 15:05:11

Hallo Thorsten,

Du hast recht, excel produziert einen Fehler auf Grund der beschränkten Rechengenauigkeit(0,99999999999999 ist für Excel = 1,0), der sich hier auf das Ergebnis auswirkt.
Du kannst den Fehler umgehen, indem Du einfach einen Wert 0,001 dazuaddierst:

=SUMMENPRODUKT((GANZZAHL(REST($A$2:$A$100;1)*10+0,001)=C2)*($A$2:$A$100<>""))

ist zwar eine Krücke, sollte aber so funzen
Gruß Ingo


Bild


Betrifft: AW: Ziffern zählen
von: Thorsten
Geschrieben am: 24.11.2003 14:58:37

Mein Fehler! Ich denke alles klappt prima.

Vielen Dank!
Thorsten


Bild

Beiträge aus den Excel-Beispielen zum Thema " Ziffern zählen"