Suche Excel-Funktion

Bild

Betrifft: Suche Excel-Funktion
von: steph@n
Geschrieben am: 26.11.2003 12:40:23

Hallo ,

ich habe folgende Tabelle für Aufwendungen und entsprechende Gebühren.


Jetzt suche ich eine Excel-Funktion, die mir aufgrund des Wertes in B10 ausgibt welcher Kostensatz
hierfür anfällt. Beachtet werden muss, dass die Aufwandswerte der Tabelle Bis-Werte sind.
D.h. die funktion müsste mir bei einem Aufwand von 750,- einen Kostensatz von 500,- ausgeben.

Kann mir jemand helfen?

Gruss Stephan

Bild


Betrifft: AW: Suche Excel-Funktion
von: ralph
Geschrieben am: 26.11.2003 12:56:19

=SVERWEIS(B10;B2:C5;1;2)

Der 4. Parameter gibt an, daß Excel bei Nicht-Finden des Werts in der Liste den nächstkleineren Wert in Spalte B auswählt und den zugehörigen Wert aus Spalte C zurückgibt. Achtung: Daten müssen sortiert nach B sein.
Gruß
Ralph


Bild


Betrifft: AW: Suche Excel-Funktion KORREKTUR
von: ralph
Geschrieben am: 26.11.2003 13:17:51

Sorry, hab Dir Blödsinn geschrieben! Eine funktionierende Lösung ist:

=BEREICH.VERSCHIEBEN(C1;VERGLEICH($H$12;B2:B5;-1);0;1;1)

Dafür müssen die Daten absteigend nach Spalte B sortiert sein.
ralph


Bild


Betrifft: AW: Suche Excel-Funktion KORREKTUR
von: steph@n
Geschrieben am: 26.11.2003 13:36:24

Hallo Ralph,

Leider krieg ich die Funktion, so wie Du sie mir geschickt hast nicht zum laufen. Könntest Du mir verbal erklären, was sie nochmalerweise machen soll?

Dank Dir!

Gruß Stephan

PS: z.B. ist $H$12 bei mir eine leere Zelle und ich weiß nicht worauf das eigentlich verweisen soll. Werd parallel mal versuchen mir über die Hilfe weiter zu helfen.


Bild


Betrifft: AW: Suche Excel-Funktion KORREKTUR
von: ralph
Geschrieben am: 27.11.2003 14:33:30

mannomann, war wohl gestern nicht mein tag.
H12 muss natürlich B10 sein, nämlich der aufwand, nach dem du suchst.
die funktion bereich.verschieben verweist auf einen bereich, der in einem bestimmten zusammenhang zu einer ursprungszelle (hier: c1) steht. Syntax:
bereich.verschieben (ausgangspunkt ; entfernung vertikal in zeilen ; entfernung horizontal in spalten ; höhe des bereichs in zeilen ; breite des bereichs in spalten).
schönen gruß!
ralph


Bild

Beiträge aus den Excel-Beispielen zum Thema " Hyperlinks entfernen"