Vervielfälltigen von Formeln(nur Teile)

Bild

Betrifft: Vervielfälltigen von Formeln(nur Teile)
von: cmp
Geschrieben am: 30.11.2003 09:28:29

Guten Tag.
Ich habe vollgendes Problem:
Seit einiger Zeit besitze ich ein Lager mit verschiedenen Teilen,
um mir meine Inventur zu erleichtern habe ich es in Excel
kompllet übernommen.
Meine Problem bezieht sich darauf, das ich sehr viele Formeln habe
die Identisch sind, die aber von einander in ein oder zwei Werten
abweichen. Wie kann ich die Formeln vervielfälltigen ohne die Abweichungen manuel zu verändern?
Hier zu ein Beispiel:
C1(Zeile1) Verbrauchte Mat.
C2(Zeile2)
C3(Zeile3) =SUMMEWENN(Ausgang!B2:Ausgang!C4000;C3;Ausgang!D2:Ausgang!E4000)
C4(Zeile4) =SUMMEWENN(Ausgang!B2:Ausgang!C4000;C4;Ausgang!D2:Ausgang!E4000)
C5(Zeile5) =SUMMEWENN(Ausgang!B2:Ausgang!C4000;C5;Ausgang!D2:Ausgang!E4000)
C...Zeile =SUMMEWENN(Ausgang!B2:Ausgang!C4000;CX;Ausgang!D2:Ausgang!E4000)
C4000 =SUMMEWENN(Ausgang!B2:Ausgang!C4000;C4000;Ausgang!D2:Ausgang!E4000)

Es ändert sich nur der Wert c3,c4,c5,c6 usw... es nimmt
SEHR viel Zeit in anspruch, das alles von Hand zu ändern,
wobei das nur ein von vielen Formeln ist.

Für Antworten Anregungen bin ich sehr dankbar.
cmp

Bild


Betrifft: AW: Vervielfälltigen von Formeln(nur Teile)
von: Klaus K.
Geschrieben am: 30.11.2003 10:17:08

Hi,
das verstehe ich nicht ganz.
Normalerweise ändert sich der Bezug automatisch, wenn Du die Zelle mit
der Formel per Drag&Drop runterziehst.
=SUMMEWENN(B22:B28;C22;D22:D28)
=SUMMEWENN(B23:B29;C23;D23:D29)
usw.
oder
=SUMMEWENN($B$22:$B$28;C22;$D$22:$D$28)
=SUMMEWENN($B$22:$B$28;C23;$D$22:$D$28)
funktioniert astrein.
Hast Du Drag&Drop aktiviert ???
Menue/Extras/Optionen
Gruss
Klaus


Bild


Betrifft: AW: Vervielfälltigen von Formeln(nur Teile)
von: cmp
Geschrieben am: 30.11.2003 10:39:22

Drag and Drop ist aktiviert
Wenn ich es runterziehe sieht das dann so aus:
=SUMMEWENN(Ausgang!B2:Ausgang!C4000;C3;Ausgang!D2:Ausgang!E4000)
=SUMMEWENN(Ausgang!B3:Ausgang!C4001;C4;Ausgang!D3:Ausgang!E4001)
=SUMMEWENN(Ausgang!B4:Ausgang!C4002;C5;Ausgang!D4:Ausgang!E4002)

soll aber so :
=SUMMEWENN(B22:B28;C22;D22:D28)
=SUMMEWENN(B22:B28;C23;D22:D28)
usw.

Was sind den die Dollar-zeichen?
Und mir fällt noch ein kann ich per Formel eine Zellen Farbe ändern?


Bild


Betrifft: AW: Vervielfälltigen von Formeln(nur Teile)
von: Klaus K.
Geschrieben am: 30.11.2003 11:00:42

Mit dem Dollar-Zeichen wird ein Bezug statisch.
Shift und 4 drücken.
=SUMMEWENN(B$22:B$28;C22;D$22:D$28)
So bleibt die Zeile statisch
=SUMMEWENN($B22:$B28;C22;$D22:$D28)
So bleibt die Spalte statisch
=SUMMEWENN($B$22:$B$28;C22;$D$22:$D$28)
So bleibt Zeile und Spalte statisch.

Jetzt per Drag&Drop runterziehen, dann kommt:
=SUMMEWENN($B$22:$B$28;C22;$D$22:$D$28)
=SUMMEWENN($B$22:$B$28;C23;$D$22:$D$28)
=SUMMEWENN($B$22:$B$28;C24;$D$22:$D$28)
usw.

Unter Menue/Format/Bedingte Formatierung kannst du die
Zelle abhängig vom Wert Färben. Diese Formatierung
wird auch per Drag&Drop übernommen.
Gruss
Klaus


Bild


Betrifft: Geschlossen
von: cmp
Geschrieben am: 30.11.2003 11:36:50

jetzt hats funktionier danke.


Bild


Betrifft: Deine Rückmeldung: "Geschlossen"...
von: andreas e
Geschrieben am: 30.11.2003 12:27:11

halte ich für sehr hilfreich !
Das zeigt, daß ein Thread zur Zufriedenheit erledigt ist !
Schöne Antwort ! Macht das Lesen hier einfacher !
Gruß und schönes WE
Andreas E


Bild

Beiträge aus den Excel-Beispielen zum Thema " Vervielfälltigen von Formeln(nur Teile)"