Microsoft Excel

Herbers Excel/VBA-Archiv

Werte vergleichen

Betrifft: Werte vergleichen von: Erich M.
Geschrieben am: 14.08.2004 12:24:58

Hallo EXCEL-Freunde,
ich suche eine Möglichkeit mit der ich verschiedene Zellen so vergleichen kann,
dass ich eine Fehlermeldung erhalte, wenn irgendeine der Zelle einen anderen
Wert hat als alle anderen Zellen.
Die Anzahl und die Stelle der Zellen soll unterschiedlich sein:


Tabelle1
 ABC
125  
2 25 
3   
423  
5  25
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Wie müsste die Formel z.B. in D1 aussehen, wenn ich die Werte in A1 bis C5 vergleiche?

Besten Dank für eine Hilfe!

mfg
Erich
  


Betrifft: AW: Werte vergleichen von: Frank
Geschrieben am: 14.08.2004 12:41:26

Hi Erich
und wqas möchtest Du für leere Zellen zurückbekommen? Auch einen Fehler?
Eine Variante (ohne Leerzellen) wäre:
=WENN(ZÄHLENWENN(A1:C5;A1)<>ANZAHL2(A1:C5);"Nicht alle Werte sind gleich";"Alle Werte sind gleich")

Frank


  


Betrifft: AW: Werte vergleichen von: Jörg Gradert
Geschrieben am: 14.08.2004 13:00:34

Hallo Frank,
Du kannst nicht wissen, ob in A1 der richtige Wert steht.

Gruss Jörg


  


Betrifft: AW: Werte vergleichen von: Frank
Geschrieben am: 14.08.2004 13:12:01

Hi Jörg
da Erich aber im Prinzip wissen wollte, ob ALLE Zahlen gleich sind, ist es eigentlich egal, mit welchem Wert ich vergleiche :-)
Einzige Einschränkung: A1 darf nicht leer sein

Frank


  


Betrifft: AW: Werte vergleichen von: Hans W. Herber
Geschrieben am: 14.08.2004 12:43:19

Hallo Erich,

siehe Beispielarbeitsmappe unter:

Mit der rechten Maustaste hier klicken und Beispielarbeitsmappe downloaden
Dieses Beispiel wird die 2278. Arbeitsmappe der Excel-CD-ROM.


gruss hans


  


Betrifft: Ergänzung von: Erich M.
Geschrieben am: 14.08.2004 13:01:44

Hallo Hans,

zunächst besten Dank!
Hätte das gerne noch verfeinert, dass ich die Zellen individuell bestimmen kann.
Habe auf Deiner CD #073799 gefunden:
Function BereichVergleich(rngEins, rngZwei) As Boolean
  Dim rngCell As Range
  Dim iCounter As Integer
  Dim bln As Boolean
  For Each rngCell In rngEins
    iCounter = iCounter + 1
    If rngCell <> rngZwei.Cells(iCounter) Then
      bln = True
      Exit For
    End If
  Next rngCell
  If bln = False Then BereichVergleich = True
End Function


Kann man das auf mehrere Zellen ausweiten?

Tabelle1
 A
125
221
32
425
525
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



So dass ich die gelben Zellen vergleichen kann?

Besten Dank nochmal!

mfg
Erich


  


Betrifft: AW: Werte vergleichen von: Christian
Geschrieben am: 14.08.2004 12:44:58

Zwei Möglichkeiten die mir eingefallen sind:

Entweder über "Daten - Gültigkeit - Ganze Zahl) nur die 25, oder jede andere Zahl zuzulassen.
oder
=WENN(A7<>25;"Achtung!";WENN(A9<>25;"Achtung";"OK"))
mit so einer Formel jede Zelle einzeln einzubinden.

Viel Spaß


  


Betrifft: AW: Werte vergleichen von: Jörg Gradert
Geschrieben am: 14.08.2004 12:56:25

Hallo Erich,

=MITTELWERT(A1:C10)=KGRÖSSTE(A1:C10;1)

liefert Wahr, wenn alle Werte gleich sind, sonst Falsch

das kannst Du noch in eine WENN() einbinden für die Fehlermeldung

=WENN(MITTELWERT(A1:C10)=KGRÖSSTE(A1:C10;1);"";"Fehler")

Gruss Jörg


  


Betrifft: AW: Werte vergleichen von: Erich M.
Geschrieben am: 14.08.2004 13:03:44

Hallo Jörg,

besten Dank; habe noch eine ergänzende Frage - siehe meine aan Hans!

mfg
Erich


  


Betrifft: AW: Werte vergleichen von: Jörg Gradert
Geschrieben am: 14.08.2004 13:46:24

Hallo Erich,
ja Du kannst mehrere, nicht zusammenhängende, Bereiche oder einzelne Zellen in die Formel schreiben, immer mit Semikolon getrennt. Z.B.

=MITTELWERT(B1:B2;C1:C3;C10)=KGRÖSSTE((B1:B2;C1:C3;C10);1)

Gruss Jörg


  


Betrifft: DANKE - Jörg; Lösung perfekt; o.T. von: Erich M.
Geschrieben am: 14.08.2004 16:00:12

.


 

Beiträge aus den Excel-Beispielen zum Thema "Werte vergleichen"