Microsoft Excel

Herbers Excel/VBA-Archiv

Landestelefonvorwahl 49 durch eine 0 ersetzen

Betrifft: Landestelefonvorwahl 49 durch eine 0 ersetzen von: Stephan
Geschrieben am: 15.08.2004 15:31:51

Hallo Forum,

bei meinem Telefonlistenvergleich (ca. 10.000 Telefonnummern) habe ich das Problem, dass in den importierten Tabellen immer mal wieder eine Telefonnummer mit der Landesvorwahl 49 ... beginnt. Insgesamt sind es vielleicht so 3.000 Stück, also zu viele, um diese 49 ... manuell in die übliche 0 ... in der Vorwahl zu ersetzten. Beispiel: https://www.herber.de/bbs/user/9663.xls

Diese Umwandlung ist aber unbedingt erforderlich, da Excel sonst den angestrebten Abgleich der Telefonnummern untereinander mittels der bedingten Formatierung =ZÄHLENWENN($A$3:$I$1000;A3)=2 nicht durchführen kann. So kann es nämlich durchaus sein, dass in der Zelle A10 die Nummer 49511446688 steht und in der Zelle I120 0511446688, und diese eigentlich identische Telefonnummer würde somit nicht ausgeworfen werden.

Ich hoffe, es weiß jemand Rat ;-)

Gruß Stephan

  


Betrifft: AW: Landestelefonvorwahl 49 durch eine 0 ersetzen von: ChrisL
Geschrieben am: 15.08.2004 15:42:15

Hi Stephan

=WENN(LINKS(A2;2)="49";"0"&RECHTS(A2;LÄNGE(A2)-2);A2)

Gruss
Chris


  


Betrifft: Super, Danke Chris für die tolle Hilfe, ob Du ... von: Stephan
Geschrieben am: 15.08.2004 22:47:23

... mir den Hintergrund dieser Formel nach der "0" vielleicht noch in zwei oder drei Sätzen erklären könntest. Wäre klasse ;-)

Gruß Stephan


  


Betrifft: AW: Super, Danke Chris für die tolle Hilfe, ob Du ... von: ChrisL
Geschrieben am: 16.08.2004 07:52:55

Hi Stephan

Wenn Links = 49 dann...

"0" plus von Rechts (Länge String - 2 Zeichen)


Gruss
Chris


 

Beiträge aus den Excel-Beispielen zum Thema "Landestelefonvorwahl 49 durch eine 0 ersetzen"