Microsoft Excel

Herbers Excel/VBA-Archiv

#N/A

  • #N/A von Florian vom 17.08.2004 18:59:59
    • AW: #N/A - von Ramses am 17.08.2004 19:04:19
      • AW: #N/A - von Florian am 17.08.2004 22:15:04
    • AW: #N/A - von Peter am 17.08.2004 19:05:37

Betrifft: #N/A von: Florian
Geschrieben am: 17.08.2004 18:59:59

Hallo,
mein Excel Sheet hat eine sehr lange Spalte mit Zahlen. Am Ende dieser Spalte moechte ich den Durchschnitt dieser Werte berechnen. Das waere alles kein Problem, wenn in der Spalte zwischendurch nicht #N/A vorkommen wuerde. Suche jetzt eine Loesung, wie ich dies am einfachsten berechnen kann, denn das #N/A kommt auch weiterhin drin vor und laesst sich nicht vermeiden, muss sogar sein.
Ich habs mit einem Wenn-Befehl versucht: =IF(F5>0,F5,0) oder =IF(F5="#N/A",0,F5).
Hat irgendwie nicht so recht klappen wollen.
Ist da draussen jemand, der eine zuendende Idee hat????
Viele Gruesse,
Florian

  


Betrifft: AW: #N/A von: Ramses
Geschrieben am: 17.08.2004 19:04:19

Hallo

"...denn das #N/A kommt auch weiterhin drin vor und laesst sich nicht vermeiden..."

Weshalb sollte sich das nicht vermeiden lassen ?

Tabelle1
 ABCD
10#NV#NV 
20#NV0 
3    
Formeln der Tabelle
C1 : =B1/A1
C2 : =WENN(ISTFEHLER(B2/A2);0;B2/A2)
 



Gruss Rainer


  


Betrifft: AW: #N/A von: Florian
Geschrieben am: 17.08.2004 22:15:04

Vielen Dank Ramses,
ich bin auf 'ISTFEHLER' nicht gekommen.
Damit ist mir sehr weitergeholfen. Nochmals vielen Dank,
viele Gruesse,
Florian


  


Betrifft: AW: #N/A von: Peter
Geschrieben am: 17.08.2004 19:05:37

Florian,
mach doch ein fach eine zweite spalte in der du NA abfragst mit einer IF abfrage und wenns NA ist setzt du es gleich 0 ansonsten die Zahl aus der eigentlcien Daten Spalte..
Einfach sollte aber funktionieren..

gruss Peter