Microsoft Excel

Herbers Excel/VBA-Archiv

Zeichenkette finden und trennen

Betrifft: Zeichenkette finden und trennen von: Jens
Geschrieben am: 19.08.2004 14:27:31

Hallo,

bei mir hat sich folgendes Problem aufgetan:

Es gibt in der Datentabelle Zellen, welche z.B. die Zeichenkette "xyz" enthalten. Diese Zellen möchte ich identifizieren. Im nächsten Schritt sollen genau diese Zeichenketten aufgeteilt (Substrings duch Leerzeichen getrennt) und in einzelne Zellen geschrieben werden.
Z.B. "hallo xyz !" soll zu "hallo" "xyz" "!" umgewandelt werden.

Danke für Eure Hilfe,
Jens.

  


Betrifft: AW: Zeichenkette finden und trennen von: Bertram
Geschrieben am: 19.08.2004 15:00:29

Hi Jens,

mit Daten-Text in Splaten sollte das funktionieren.

Gruß
Bertram


  


Betrifft: AW: Zeichenkette finden und trennen von: Boris
Geschrieben am: 19.08.2004 15:05:11

Hi Bertram,

dann wird aber alles getrennt - auch Zellen, die nicht "xyz" enthalten.

Grüße Boris


  


Betrifft: AW: Zeichenkette finden und trennen von: Boris
Geschrieben am: 19.08.2004 15:04:14

Hi Jens,

ne reine Formellösung - funktioniert dann, wenn deine zu durchsuchenden Daten in EINER Spalte stehen.

Im Beispiel stehen sie in Spalte A - beginnend bei A1.Dein Blatt heisst "Tabelle1". Selektiere B1 (wichtig!!!), dann:

1.)
Einfügen-Name-Definieren, Name: C
Bezieht sich auf:
=AUSWERTEN("{"""&WECHSELN(Tabelle1!$A1;" ";""";""")&"""}")

Jetzt schreibe in B1 folgende Formel:
=WENN(ANZAHL(SUCHEN("xyz";$A1));WENN(SPALTE(A1)>ANZAHL2(C);"";INDEX(C;SPALTE(A1)));WENN(SPALTE(A1)=1;$A1;""))
und kopier sie sowohl nach rechts als auch nach unten.

Anschließend kannst du die ganzen Formelspalten kopieren und über "Inhalte einfügen" wieder einfügen.

Grüße Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Zeichenkette finden und trennen"