Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn bei gleichen Spalten

Betrifft: zählenwenn bei gleichen Spalten von: Bernd
Geschrieben am: 20.08.2004 14:45:36

Folgendes Problem,

ich habe eine Matrix mit gleichen Spaltennamen : 2x August, 3x September etc.
nun möchte ich mit zählenwenn wissen, wieviele Einträge von "x" in der Matrix sind die die Überschrift "August" haben, ohne den August-Bereich durch genaue Spaltenbezeichnung zu spezifizieren.

Man müßte hier ggf. zwei Funktionen zusammenschließen in etwa :

= zählenwenn(14:26;"x") wenn (in der gefundenen Spalte Nr. 13) August steht.

  


Betrifft: AW: zählenwenn bei gleichen Spalten von: Boris
Geschrieben am: 20.08.2004 14:58:40

Hi Bernd

in A1:J1 deine Monatsnamen (als Text) - darunter bis Zeile 100 dein "x".

=SUMMENPRODUKT((A1:J1="August")*(A2:J100="x"))

Grüße Boris


  


Betrifft: AW: zählenwenn bei gleichen Spalten von: bernd
Geschrieben am: 20.08.2004 15:12:12

Hallo Boris,

das ist fast super. Geht das aber auch ohne dem Textformat, z.b. mit einer Zahl 8*30 und der Formatierung MMMM ?

Bis hier her schon mal super !!!

Gruß Bernd


  


Betrifft: AW: zählenwenn bei gleichen Spalten von: bernd
Geschrieben am: 20.08.2004 15:39:09

Super das klappt auch ohne Text und man kann auch eine Zahl oder Formeleinfügen - natürlich ohne "".


Vielen Dank Boris !!!


  


Betrifft: AW: zählenwenn bei gleichen Spalten von: Geschlossen
Geschrieben am: 20.08.2004 16:52:20




 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn bei gleichen Spalten"