Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleiche Spalten

Betrifft: Vergleiche Spalten von: Axel
Geschrieben am: 24.08.2004 09:09:00

Hallo,
hab mal wieder ein Problem.

Ich möchte Zellen zählen die in zwei Spalten aus zwei verschiedenen Tabellen gleich sind.
Hab schon ne Weile experimentiert mit diesen Formeln was soll ich ändern ?
=SUMMENPRODUKT((B2:B1000=B2)*(B2*(AD2:AD1000)))
oder
=SUMMENPRODUKT(B:B=B2)*(AD:AD=B2) Ergebnis #ZAHL!

  


Betrifft: AW: Vergleiche Spalten von: Axel
Geschrieben am: 24.08.2004 09:12:03

äääh.... in den Spalten stehen Kundennummern !


  


Betrifft: AW: Vergleiche Spalten von: HermannZ
Geschrieben am: 24.08.2004 09:26:17

hallo Axel,

Um nur die Übereinstimmungen zu zählen:
---=ZÄHLENWENN(Tabelle12!A10:A20;1)+ZÄHLENWENN(Tabelle15!A10:A20;1)---

hiermit werden in den beiden Spalten der Tabelle 12 und 15 im Bereich A10 und A20 die Übereinstimmungen mit der 1 gezählt.

Gruß hermann


 

Beiträge aus den Excel-Beispielen zum Thema "Vergleiche Spalten"