Microsoft Excel

Herbers Excel/VBA-Archiv

Spannweite

Betrifft: Spannweite von: Harald E
Geschrieben am: 24.08.2004 10:14:51

Hallo zusammen,

ich such schon die ganze Zeit nach einer einfacheren Formel zur Ermittlung der Spannweite verschiedener Werte (also Differenz Größt- zu Kleinstwert)

Hier meine aktuelle Formel für Werte in B3:B12(mit #NV-Blocker ;-).
=WENN(ISTFEHLER(KGRÖSSTE(B3:B12;1)-KKLEINSTE(B3:B12;1));"";(KGRÖSSTE(B3:B12;1)-KKLEINSTE(B3:B12;1)))

Eine direkte Formel ist mir bisher nicht ins Auge gefallen.
Vielleicht weiß ja jemand weiter.

Gruß
Harald

  


Betrifft: AW: Spannweite von: heikoS
Geschrieben am: 24.08.2004 10:22:04

Hallo Harald,

da Du nur in einer Spalte suchst und nur den kleinsten und größten Wert haben möchtest, sollte das auch über Min() und Max() machbar sein.

Gruß Heiko


  


Betrifft: AW: Spannweite von: Harald E
Geschrieben am: 24.08.2004 10:33:37

Vielen Dank Heiko,

das hat aber (für mich) den Nachteil, das bei noch nicht ausgefüllten Datenreihen als Ergebnis eine 0 steht. Das Feld soll bitte leer sein, wenn noch keine Werte eingetragen sind.
Meine Vorstellung wäre die Formel =Spannweite(B3:B12)....nur die Funktion Spannweite gibts nicht (bzw. nicht das ich wüßte), obwohl es in der Statistik häufig gebraucht wird.

Gruß
Harald


  


Betrifft: AW: Spannweite von: HermannZ
Geschrieben am: 24.08.2004 10:30:07

hallo Harald

geht auch mit max und min:

---=WENN(MAX(B3:B12)-MIN(B3:B12)=0;"";MAX(B3:B12)-MIN(B3:B12))

Gruß hermann


  


Betrifft: AW: Spannweite von: Harald E
Geschrieben am: 24.08.2004 10:37:12

Auch dir vielen Dank,

zumindest nimmt es auch das Nullergebnis raus, wenn keine Einträge vorhanden sind.

....und statistisch gesehen ist es nahezu unmöglich eine Spannweite von 0 zu erreichen, da würde das Feld nämlich auch leer bleiben.

Gruß
Harald


  


Betrifft: AW:Danke für die Rückantwort oT. von: HermannZ
Geschrieben am: 24.08.2004 10:51:43

..