Microsoft Excel

Herbers Excel/VBA-Archiv

Viele Wenn-Formeln

Betrifft: Viele Wenn-Formeln von: Heinrich
Geschrieben am: 24.08.2004 12:09:38

Guten Tag
Möchte Wenn-Funktionen evtl durch eine elegantere Lösung ersetzen.
Evtl. wird ja dann auch die Größe der Tabelle reduziert.
Da nur 7 wenn-Funktionen verschachtelt werden können,habe ich ab der 6. Funktion auf eine Zelle verwiesen, in der wiederum 7 wenn-Funktionen verschachtelt werden können.
Die Tabelle geht über 474 Zeilen und in jeder Zeile steht diese Formel.
Würde sich durch eine elegantere Lösung die Größe der Tabelle reduzieren ?



Viele Grüße
Heinrich

  


Betrifft: wo ist meine Glaskugel? von: Günther Oppold
Geschrieben am: 24.08.2004 12:20:57

Hi Heinrich

1. - man kann mehr als 7 Wenn-Abfragen in eine Zelle bringen!
z.b.: Wenn(A1=1;"eins";wenn(A1=2;"zwei"...wenn(A1=7;"sieben";)))))))&wenn(A1=8;"acht";....)))))))&wenn(
oder: =WENN(A1=1;"eins";)&WENN(A1=2;"zwei";)&....

2. um Dir eine bessere Lösung vorschlagen zu können (oft hilft eine Verweis-Formel bzw eine Index-Formel) müsste man genau wissen, welche Abfragen in den Formeln erfolgen.


Günther


  


Betrifft: AW: Viele Wenn-Formeln von: Andre
Geschrieben am: 24.08.2004 12:21:36

Hi,

das kommt auf deine Tabelle an. Grundsätzlich vereinfacht VBA einiges! Besonders hinsichtlich Übersichtlichkeit, Handling aber auch Größe einer Tabelle.

Lad doch mal deine Datei hoch, durch Beispiele läßt sich auch vieles vereinfachen.

Gruß Andre


  


Betrifft: AW: Viele Wenn-Formeln von: Rainer
Geschrieben am: 24.08.2004 12:54:05

Hallo Heinrich,
Verschachtelungen von mehr als 7 Wenn-Funktionen lassen sich mit Bedingungsprüfungen umgehen.
siehe Datei
https://www.herber.de/bbs/user/10019.xls
Gruss
Rainer


  


Betrifft: AW: Hier meine Wenn-Formeln von: Heinrich
Geschrieben am: 26.08.2004 08:45:55

=WENN(UND(G23="Guthaben";G24<>"Restbeitrag";G24<>"Restbeitrag <50";G24<>"Guthaben";SUMMEWENN(E$12:E23;">0";F$12:F23)-SUMMEWENN(G$12:G23;"Zahlungseingang am :";F$12:F23)<=0);"l";WENN(B24="l";"l";WENN(UND(E21>1;G23="Guthaben");"l";WENN(UND(G22="Zahlungseingang am :";G23="Guthaben");"l";WENN(UND(G23<>"Restbeitrag";SUMMEWENN(G22:G23;"Restbeitrag";F22:F23)>0;SUMMEWENN(G22:G23;"Zahlungseingang am :";F22:F23)>0;SUMMEWENN(G22:G23;"Restbeitrag";F22:F23)-SUMMEWENN(G22:G23;"Zahlungseingang am :";F22:F23)=0);"l";WENN(UND(SUMMEWENN(E22:E23;">0";F22:F23)>0;SUMMEWENN(G22:G23;"Zahlungseingang am :";F22:F23)>0;SUMMEWENN(E22:E23;">0";F22:F23)-SUMMEWENN(G22:G23;"Zahlungseingang am :";F22:F23)=0);"l";Tabelle2!F24)))