Microsoft Excel

Herbers Excel/VBA-Archiv

Summenfunktion

Betrifft: Summenfunktion von: Gerhard
Geschrieben am: 24.08.2004 16:19:20

Hallo,

ich habe eine Tabelle mit Produktionsspalten und Lieferspalten pro Kalenderwoche. Diese folgen aufeinander, also PRD KW1, LF KW1, PRD KW2, LF KW2, ..., PRD KW52, LF KW52.
Nun möchte ich über die PRD Spalte und LF Spalte eine Summe bilden, also die Zahlen in den PRD-Zeilen und LF-Zeilen zu summieren.

Welche Möglichkeiten gibt es hierfür?


Gerhard

  


Betrifft: AW: Summenfunktion von: Boris
Geschrieben am: 24.08.2004 16:39:49

Hi Gerhard,

in Zeile 1 sind deine Überschriften ("PRD KW1", "LF KW1" etc...)
In den Zeilen 2 bis 100 die zu summierenden Werte.

Dazu diese Formel:
=SUMMENPRODUKT(ISTZAHL(SUCHEN("PRD";1:1))*2:100)

Für LF dann analog.

Diese Formel darf erst irgendwo ab Zeile 101 eingetragen werden, da es sonst zu´einem Zirkelbezug kommt. Alternativ die Zeilengrößen verkleinern (z.B. von 2:100 auf A2:H100)

Grüße Boris


  


Betrifft: Danke, funktioniert super von: Gerhard
Geschrieben am: 24.08.2004 16:49:41

Danke Boris für Deine Hilfe

Gerhard