Microsoft Excel

Herbers Excel/VBA-Archiv

Steuerformeln

Betrifft: Steuerformeln von: Erich M.
Geschrieben am: 24.08.2004 21:26:13

Hallo EXCEL-Freunde,

wer hat Interesse, beiliegende Datei anzusehen und kann evtl. herausfinden,
wo der Fehler in der Berechnung der Steuerformeln liegt. Dabei geht es um einen
Vergleich der Tabellen lt. BFM mit der Berechnung in EXCEL.
Die Datei meine ich ist soweit selbsterklärend.
https://www.herber.de/bbs/user/10042.xls

Besten Dank für eine Hilfe!

mfg
Erich

  


Betrifft: AW: Steuerformeln von: Andreas Walter
Geschrieben am: 25.08.2004 12:57:25

- wer hat Interesse, beiliegende Datei anzusehen und kann evtl. herausfinden,
wo der Fehler in der Berechnung der Steuerformeln liegt

Was ist der Fehler? Wo ist der Fehler?
Bei Diff? Bei welcher Diff?

- Die Datei meine ich ist soweit selbsterklärend.
Bedaure - mir gegenüber hat die Tabelle sich nicht selbst erklärt.
Was sind T1958, T1965, T1975. Die Tabellen ab bestimmten Jahren?

Ich tippe darauf, dass Du entweder
- die falsche Funktion aufrufst
oder
- falsch rundest bzw. an der falschen Stelle rundest.

Beispiel: C7 zeigt 28; beinhaltet 27,6.
G7 zeigt 28; beinhaltet aber 27,6097615845958

Ich kenne die BMF Unterlagen nicht, aus denen die Formeln hergestellt wurden.


  


Betrifft: AW: Steuerformeln von: Erich M.
Geschrieben am: 25.08.2004 21:35:56

Hallo Andreas,

genau die angezeigten und farblich markierten Differenzen sind das Problem.
Nachdem die EXCEL-Ergebnisse innerhalb eines bestimmten Bereiches mit den offiziellen
Steuertabellen identisch sind, müssen die EXCEL-Formeln irgendwo einen Fehler haben.
Und da setzt das Problem ein:
T1958 heisst Tabelle (Formel) aus dem Jahr 1958; deswegen habe ich die Zusatztabellen
mit den offiziellen Formeln nach §32a eingefügt.

Die Rundungsproblematik ist mir bewusst; spielt aber bei der Größe der Differenzen keine
Rolle.

Allerdings hatte ich unterstellt, dass sich grundsätzlich jemand die Mühe macht, der sich mit den steuerlichen Dingen etwas auskennt, weshalb ich keine nähere Beschreibung in der Anfrage hinterlegt habe.

mfg
Erich




  


Betrifft: Wer kennt sich mit §32a Einkommenssteuer von: Andreas Walter
Geschrieben am: 26.08.2004 09:12:08

Da ich jedes Jahr von der BMF der Ablaufdiagramm für die Berechnung von Lohnsteuer in den Händen habe, kenne ich mich schon a bisserl aus. Die Einkkommensteuerberechnung und §32a sind mir aber nicht geläufig. Ich tippe immer noch auf einer ausgelassenen Rundung o.ä.
Ich stelle die Frage aber als "offen" ein


  


Betrifft: Horner-Schema war Problem-Lösung von: Erich M.
Geschrieben am: 27.08.2004 07:04:13

Hallo Andreas,

hier die Lösung - und fürs Archiv:
Vergleich (2)
 ABCDEFGHI
1  lt. BFMFormelaufbau im Excel-Rechner
2DMAbger.ZVEYDMDiff
320.00039.1176.3701.303,039.090,015,09012.4606.3700
425.00048.8968.551814,048.840,024,84016.7258.5510
Formeln der Tabelle
B3 : =A3*Euro
D3 : =ABRUNDEN(B3/30;0)
E3 : =D3*30
F3 : =((E3-24000)/1000)
G3 : =SUMME(6358+382*F3+1,572*F3^2-0,006*F3^3)
H3 : =ABRUNDEN(G3/Euro;0)
I3 : =C3-H3
B4 : =A4*Euro
D4 : =ABRUNDEN(B4/60;0)
E4 : =D4*60
F4 : =(E4-24000)/1000
G4 : =SUMME(6358+382*F4+1,572*F4^2-0,006*F4^3)
H4 : =ABRUNDEN(G4/Euro;0)
I4 : =C4-H4
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Mit dem Zeichen ^ in den Formeln ergeben sich die richtigen Berechnungen!

mfg
Erich