Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Funktion aus Zeichenkette

Betrifft: Wenn Funktion aus Zeichenkette von: Antje_Da
Geschrieben am: 24.08.2004 21:21:21

Hallo!

Ich habe folgendes Problem. In einer Zelle steht eine PLZ und der Ort. Ich muss nun anhand der PLZ rausfiltern welche PLZ Ausland ist und welche nicht.

Der Inhalt sieht ungefähr so aus: "D-12345 Ort" (D für Deutschland) oder "NL-1234 Ort" (NL für Niederlande).

Ausgegeben werden soll in der gleichen Zeile, nur andere Spalte ein A für Ausland oder ein I für Inland.

Wer kann mir dabei helfen? Finde leider keine Lösung und benötige diese dringend. Vielen Dank

Antje

  


Betrifft: AW: Wenn Funktion aus Zeichenkette von: P@ulchen
Geschrieben am: 24.08.2004 21:27:57

Hallo Antje,

wenn die PLZ in A1 dann zB. in B1: =WENN(LINKS(A1;1)="D";"I";"A")



Gruß aus Leipzig
P@ulchen

Das Forum lebt auch von den Rückmeldungen !


  


Betrifft: AW: Wenn Funktion aus Zeichenkette von: andreas e
Geschrieben am: 24.08.2004 22:15:41

Hallo Paulchen,

hoffentlich hat sie dann keinen unserer dänischen Nachbarn in der Datenbank !

Müsste dann eben noch ein zusatz rein

 
 AB
1DK-123Ausland
2D-123Inland
Formeln der Tabelle
B1 : =WENN(UND(LINKS(A1;1)="D";LINKS(A1;2)<>"DK");"Inland";"Ausland")
B2 : =WENN(UND(LINKS(A2;1)="D";LINKS(A2;2)<>"DK");"Inland";"Ausland")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



gruß
andreas e


  


Betrifft: AW: Wenn Funktion aus Zeichenkette von: OttoH
Geschrieben am: 24.08.2004 22:28:29

Hi Fans,

was ist mit B2 : =WENN(LINKS(A2;2)="D-";"Inland";"Ausland")

Gruß OttoH


  


Betrifft: sieht schon fast perfekt aus... von: P@ulchen
Geschrieben am: 24.08.2004 22:34:45

mal abwarten, was passiert, wenn Boris diesen Thread liest...da werden unsere Formeln sicher noch um 50 % eingekürzt...



Gruß aus Leipzig
P@ulchen


  


Betrifft: Schäm...und Asche auf mein Haupt... :-(( oT von: P@ulchen
Geschrieben am: 24.08.2004 22:31:15




  


Betrifft: AW: Schäm...und Asche auf mein Haupt... :-(( oT von: Antje
Geschrieben am: 25.08.2004 19:50:25

Hi!

Ich danke Euch vielmals für die schnelle Hilfe. Das funktioniert Super.
Ach übrigens. Habe folgende Formel genommen. Die ist ausreichend.

=WENN(LINKS(C2;2)="D-";"I";"A")

Danke
Liebe Grüße
Antje


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Funktion aus Zeichenkette"