Microsoft Excel

Herbers Excel/VBA-Archiv

DIenstplan

Betrifft: DIenstplan von: Georg O.
Geschrieben am: 25.08.2004 08:58:37

Hallo

Ich habe eine (so glaube ich) sehr komplexe Frage.
In dem Betrieb in dem ich arbeite werde ich zu unterschiedlichen Zeiten, an unterschiedlichen Objekten, zu unterschiedlicher Bezahlung eingesetzt. Dabei habe ich auch Nacht- und Wochenenddienst. Die Berechnung der Nachtschicht beginnt um 20:00 und endet um 06:00 Uhr.
Bisher trage ich die Zeiten ( ohne irgendeine Funktion) in Arbeitsballt ein und errechne mir die geleisteten Stunden "per Hand"
Nun möchte ich nur die Anfangs- und Endzeiten eintragen und die Berechnung der Stunden soll automatisch erfolgen.
Ihr würdet mir sehr helfen wenn ihr mal über meine Tabelle schauen würdet und mir sagen würdet wie ich das bewerkstelligen kann

https://www.herber.de/bbs/user/10051.xls


MfG

Georg O.

  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 25.08.2004 10:30:31

Hallo Georg,
Du solltest die Uhrzeiten nicht in einer verbundenen Zelle darstellen.
Damit kann man nicht rechnen.
Vorschlag: mit Hilfszelle(zB. AK3)
In F2: 05:45 ,; In I2: 15:45
Nun in AK3: (I2 - F2)*24
In G7 : = AK3 und fertig!!

Gruß
AndréL.


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 25.08.2004 11:04:42

Soweit so gut.Dann habe ich die Stunden ausgerechnet. Aber ich muss diese Stunden noch immer per "Hand" den einzelenen Objekten zuordnen. Ich werde aber ersmal deinen Vorschlag umsetzen. Vielen Dank.
Hat noch jemand einen Vorschlag zum oben genannten Problem? Mit meinem Latein bin ich nämlich am Ende. Das einzige was mir noch einfallen würde ist, dass ich jede Zeit mit dem Objekt in Verbindung bringe( https://www.herber.de/bbs/user/10072.xls
)und da hab ich keine Idee wie das funktionieren soll.
Selbst wenn das klappt, hab ich noch das PRoblem, dass ich noch wissen muss an welchen Stunden Zuschläge ( Nacht/ Feiertag und Sonntagszuschlag) gezahlt werden. Man man man, mir raucht der Kopf

Georg


  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 25.08.2004 13:03:37

Hallo Georg,
das ist erstmal ein Ansatz von mir.

https://www.herber.de/bbs/user/10087.xls

In A2 muß man die SchichtNr. eingeben.
Gruß
AndréL.


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 25.08.2004 13:29:48

Danke Dir. Das ist eine echte Hilfe. Ich werd das erstmal umsetzten, damit ich heute wenigsten ein Erfolgserlebnis habe.
Ähnlich hab ich mir das auch gedacht, wusste aber in keinster Weise welche Formel ich anwenden soll.....
Dann bleibt "nur" noch das Problem der Tag/Nacht/Sonn- und Feiertagsstunden.

Nochmals vielen vielen Dank

Georg


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 26.08.2004 08:48:06

ICh hab nun deine Vorschläge in die Tabelle eingearbeitet. Nun hab ich aber einen Fehler in der Berechnung der Schichten. Aus der Hilfe für den Fehler werd ich nicht schlau.
https://www.herber.de/bbs/user/10124.xls
Vielleicht kann man jemand drüber schauen.

Danke

Georg O.


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 26.08.2004 09:34:56

Ich hab nun foglendes probiert in meine Tabelle einzugeben aber immer mit einem anderen Ergeniss: =WENN(A2="1";"100";1);(WENN(A2="0";0))Hier hat sich ein Fehler eingeschlichen den ich nicht erkennen kann
Damit wollte ich erreichen das in jedem Fall eine Zahl ( und wenn auch nur die 0) in der entsprechenden Zeile steht so das die Berechnung der Schichten erfolgen kann. Steht keine Zahl in der Zeile bekomme ich eine Fehlermeldung, wie ihr in der Tabelle im Beitrag davor sehen könnt.
Bitte um einen Tipp


MfG

GEorg O.


  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 26.08.2004 11:56:42

Noch ein Vorschlag,
nur noch die Daten eintragen.

https://www.herber.de/bbs/user/10140.xls

Gruß
AndréL.
Ansonsten:
email: a1 (@) andre-lallemand.de


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 26.08.2004 12:46:13

Danke für Deine Idee. Ich muss mal schauen was nun am besten für mich geeignet ist.
Für mein obenstehendes Problem hab ich eine Formel gefunden.
=WENN(A2=0;A2;WENN(UND(A2>=1;A2<=100);1;""))
Hätte ich auch selber drauf kommen können. Aber mir fehlen die ganzen "Begriffe".

Nochmal vielen Dank

Georg O.


  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 26.08.2004 13:13:14

Warum so umständlich??
WENN(A2="";0;1)
mehr willst Du doch nicht, oder?
Gruß
AndréL.


  


Betrifft: AW: DIenstplan von: Georg O.
Geschrieben am: 26.08.2004 15:02:14

Ich hab deine Lösung nicht probiert aber die hätte sicherlich auch funktioniert ;-)
Die Tabelle ist nun fast perfekt. Nur eine Sache hätte ich gerne noch eingebaut.
Die Stunden der jeweiligen Schicht in der richtigen Spalte und Zeile.
Aber das ist fast ein Ding der Unmöglichkeit. Dazu müsste man nämlich mit einem Kalender arbeiten (für Sonn- Feiertage) und irre Formel schreiben die dafür sorgen das die ausgegeben Werte ist die richtigen Zeilen/Spalten (Objekte- Tag/ Nacht/ Sonn/ Feiertag) kommen.
Ich Stell meine (unsere) bisherigen Behmühungen mal hier rein vielleicht kann ja noch jemand was damit anfangen.
https://www.herber.de/bbs/user/10167.xls

Georg O.


  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 27.08.2004 01:43:57

Hi Georg,
das letzte Problem ist etwas für die Formel-Profis(bin ich nicht)

Habe Frage auf offen gelassen.
Schau doch mal auf die Seite von:
http://www.excelformeln.de/uberuns.html
Gruß
AndréL.


  


Betrifft: AW: DIenstplan von: AndréL.
Geschrieben am: 27.08.2004 01:44:07

Hi Georg,
das letzte Problem ist etwas für die Formel-Profis(bin ich nicht)

Habe Frage auf offen gelassen.
Schau doch mal auf die Seite von:
http://www.excelformeln.de/uberuns.html
Gruß
AndréL.