Microsoft Excel

Herbers Excel/VBA-Archiv

ergebnis durch bedingte auswahl

Betrifft: ergebnis durch bedingte auswahl von: genmaicha
Geschrieben am: 25.08.2004 16:50:41


hi!

hab heute meine frage schon gestellt, jedoch warscheinlich weil ich falsch formuliert habe, eine nicht ganz brauchbare antwort bekommen. da hier soviel los ist poste ich mein problem einfach anders formuliert neu:

also, folgendes problem:
in zelle a1 wähle ich einen begriff aus "z.b. : gas, hod oder opp" gas hat den wert 3, hod den wert 2 und opp den wert 1,5. ich möchte nun bei auswahl des jeweiligen begriffes in zelle a1, dass in zelle b1 der jeweils zugewiesene wert des ausgewählten begriffes erscheint. wichtig: es sind an die 50 verschiedene begriffe in zelle a1 zur auswahl möglich. bitte beachten.

danke im voraus!

  


Betrifft: AW: ergebnis durch bedingte auswahl von: Dr.
Geschrieben am: 25.08.2004 16:53:59

No prob. Gültigkeitsliste für die auszuwählenden Begriffe und den Wert rechts ziehst Du Dir per SVERWEIS dazu.


  


Betrifft: typischer SVerweis von: Günther Oppold
Geschrieben am: 25.08.2004 16:54:44

Hi

lege zuerst eine Matrix mit den 50 Begriffen und Werten an, dann über Sverweis den Wert zuordnen

Tabelle5
 AB
1gas3
2hot2
3opp1,5
4  
5  
6  
7gas3
8gas3
9opp1,5
10hot2
Formeln der Tabelle
B7 : =SVERWEIS(A7;A$1:B$4;2;0)
B8 : =SVERWEIS(A8;A$1:B$4;2;0)
B9 : =SVERWEIS(A9;A$1:B$4;2;0)
B10 : =SVERWEIS(A10;A$1:B$4;2;0)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

  


Betrifft: AW: ergebnis durch bedingte auswahl von: Eda
Geschrieben am: 25.08.2004 17:00:26

Hallo

will mich mal dran versuchen:

Ich nehme an Du hast eine separate Tabelle mit zwei Spaten (Begriffe und Werte)
und
In der Zelle A1 wird einer der Begriffe aus der Tabelle stehen (womöglich als Liste).

Du möchtest nun in der Zelle B1 den entsprechenden Wert haben.

Machs doch mit =SUMMEWENN(SpalteBegriffe;A1;SpalteWerte) und raus kommt das Ergebnis.
Das funktioniert, wenn jeder Begriff in der SpalteBegriffe nur einmal vorkommt.

(Wenn die Wert aber keine Zahlen sind, dann empfehle ich folgendes:
=INDEX(SpalteWerte;VERGLEICH(A1;SpalteBegriffe;0))
)

Hoffe das hilft, Eda


  


Betrifft: AW: ergebnis durch bedingte auswahl von: genmaicha
Geschrieben am: 25.08.2004 17:01:25


danke!

aber wie mache ich das in nur einer "ergebniszelle" auswahlzelle ist a1 und je nach auswahl ist das ergebnis "nur" in b1?


  


Betrifft: AW: ergebnis durch bedingte auswahl von: Dr.
Geschrieben am: 25.08.2004 17:03:51

1. Liste machen mit zwei Spalten. Erste Spalte Suchbegriffe, zweite Spalte die dazugehörigen Werte

2. Klick in A1, gehe zu Daten-Gültigkeit, wähle dort Liste, und wähle den Bereich Deiner Werteauswahl (erste Spalte). Damit haste schon mal die Auswahlliste.

3. in B1 schreibst: =sverweis(A1;Adresse der beiden Spalten;2;FALSCH)

Thats it.


  


Betrifft: AW: ergebnis durch bedingte auswahl von: Eda
Geschrieben am: 25.08.2004 17:07:05

Menü: Daten - Gültigkeit... - Einstellungen - Zulassen: Liste

und dann in Quelle SpalteBegriffe markieren

funktioniert zumindest, wenn alles auf dem gleichen Blatt ist.


 

Beiträge aus den Excel-Beispielen zum Thema "ergebnis durch bedingte auswahl"