Microsoft Excel

Herbers Excel/VBA-Archiv

sortieren

Betrifft: sortieren von: Peter Knierim
Geschrieben am: 25.08.2004 20:29:56

https://www.herber.de/bbs/user/10118.xls

Hallo benötige mal wieder Hilfe
unter dem obigem Link möchte ich gern die Datei in Spalte D sortieren.
Ich möchte aber so sortieren, das auch die letzten Stellen nach Größe sortiert werden.
Die Originalliste geht über mehrere tausend Zeilen.
Gruß Peter

Also:
1.1.1.33.1 1. WERT
1.1.1.33.10
1.1.1.33.11
1.1.1.33.12
1.1.1.33.13
1.1.1.33.16
1.1.1.33.17
1.1.1.33.18
1.1.1.33.19
1.1.1.33.2 2.WERT
1.1.1.33.20
1.1.1.33.21
1.1.1.33.22
1.1.1.33.23
1.1.1.33.24

  


Betrifft: AW: sortieren von: Ulf
Geschrieben am: 25.08.2004 20:47:53

Und wo soll da z.B. 1.1.1.33.0 einsortiert werden?
Geht nur mit Hilfsspalte oder massiv VBA, aber bei mehreren tausend Werten?

Ulf


  


Betrifft: AW: sortieren von: ExceL
Geschrieben am: 25.08.2004 21:01:10

hi

folgende Formel in L2 und einen doppelklick auf dem autoausfüllpkt.
nach dieser spalte kannste sortieren
danach wieder löschen.

=WENN(WECHSELN(D2;".";"")*1<999999;(LINKS(WECHSELN(D2;".";"");5)&"0"&RECHTS(WECHSELN(D2;".";"")));WECHSELN(D2;".";""))*1


Gruß
Christian


  


Betrifft: AW: sortieren von: Peter Knierim
Geschrieben am: 25.08.2004 21:50:01

Hallo Christian
klappt super denke mal man kann diese Formel auch in einen VBA code packen
und dann gleich den Sortiergang mit einpflegen.
Vielen Dank und Gruß Peter


  


Betrifft: Das kostet ein online Bier :-) von: Excel
Geschrieben am: 25.08.2004 22:11:19

hi

Sub uff()
Range(Cells(2, 12), Cells([a65536].End(xlUp).Row, 12)).FormulaLocal = "=WENN(WECHSELN(D:D;""."";"""")*1<999999;(LINKS(WECHSELN(D:D;""."";"""");5)&""0""&RECHTS(WECHSELN(D:D;""."";"""")));WECHSELN(D:D;""."";""""))*1"
 Range(Cells(1, 1), Cells([a65536].End(xlUp).Row, 12)).Sort Key1:=Range("L2"), Order1:=xlAscending, Header:= _
        xlGuess, OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom, _
        DataOption1:=xlSortNormal
Columns(12).ClearContents
End Sub


Gruß
Christian


  


Betrifft: AW: Das kostet ein online Bier :-) von: Peter Knierim
Geschrieben am: 26.08.2004 23:12:42

Hallo
habe auch eine Lösung gefunden, aber deine ist viel schöner und komfortabler

nochmals vielen Dank an Dich Christian und auch an das ganze Forum einfach spitze

Gruß Peter


 

Beiträge aus den Excel-Beispielen zum Thema "sortieren"