Microsoft Excel

Herbers Excel/VBA-Archiv

Summenbereich automatisch verlängern / erkennen

Betrifft: Summenbereich automatisch verlängern / erkennen von: Bastian
Geschrieben am: 25.08.2004 21:37:17

Hallo,

ich würde gerne in einem Sheet die Summe einer Spalte bilden. Wieviele Zeilen ausgefüllt sind ist allerdings nicht immer gleich. D.h. ich möchte, dass sich der Summenbereich nach unten verlängert, wenn ich dort eine weitere Zeile ausfülle.
Jetzt weiß ich nur leider nicht, wie bzw. ob das überhaupt realisiert werden kann...

Vielen Dank für Eure Hilfe! Gruß,

Bastian

  


Betrifft: AW: Summenbereich automatisch verlängern / erkennen von: Ulf
Geschrieben am: 25.08.2004 21:51:47

Bilde die Summe oben, dann ist es Wursch, wieviel nach unten kommt.

Ulf


  


Betrifft: AW: Summenbereich automatisch verlängern / erkennen von: ExceL
Geschrieben am: 25.08.2004 21:52:47

hi

würde schon gehen

aber reicht dir das nicht

 AB
11 
2  
3  
4  
51 
6 =SUMME(A:A)
7  
81 
9 {=SUMME(INDIREKT("a1:a"&MAX((A1:A10000<>"")*ZEILE(1:10000))))}
10  
11  
121 
13  
14  
15  
16  
171 





die zweite formel ist ein´Array die {} werden nicht eingegeben sondern mit STRG+Umschalt+Enter abgeschlossen

Gruß
Christian


  


Betrifft: erledigt von: Beate Schmitz
Geschrieben am: 26.08.2004 00:07:10

Hallo Bastian,

der Thread ist gelöst unter:
http://www.excel-center.de/forum/read.php?f=1&i=74673&t=74673

Und als Info für dich: Man sollte nicht die gleiche Frage in verschiedenen Foren gleichzeitig posten. Das nennt man Crossposting, kannst dich hier schlau zu machen:

http://www.office.gmxhome.de/downloads/OH_Crossposting.jpg

Ich geh' in deinem Fall von Unerfahrenheit mit Foren aus. Aber nimm den Rat mit.

Gruß,
Beate


  


Betrifft: AW: erledigt von: Ulf
Geschrieben am: 26.08.2004 00:12:34

Deine Begründung gegen eine Summe(A:A) ist schon haarsträubend, wie so einige andere
Beiträge von dir. Wo hast du diesen Unsinn eigentlich aufgeschnappt?

Ulf


  


Betrifft: @ Ulf von: Beate Schmitz
Geschrieben am: 26.08.2004 00:23:48

Hallo Ulf,

habe ich Garantie für die Qualität meiner Beiträge gegeben? Jeder hilft so gut er kann, ich kann nun mal nicht besser! Sorry! Die Frager haben ja meist eine Auswahl von Antworten und ich kann damit leben, wenn es Bessere gibt. Ich versuche, auch daraus zu lernen! Insgesamt wohl der Sinn von Foren.

Du beziehst dich in deiner Kritik besonders auf Punkt 2 meiner folgenden Erläuterung:

Gegen =SUMME(A:A) sprechen eigentlich 2 Aspekte:
1.) ein viel zu großer Bereich als nötig wird abgeklappert, um zum Ergebnis zu gelangen.
2.) Oft stehen ja die Summenformeln in der fixierten Zeile 1 und die Summe geht erst von Zeile 2 an abwärts. Und dann wird deine Formel teuflisch...

Und wenn ich das mal hier abbilde (und A4 ist die tiefste Zelle in A), solltest du verstehen, wie ich es gemeint habe:

Tabelle1
 A
18100
212
315
415
Formeln der Tabelle
A1 : =SUMME(A:A)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Übrigens habe ich nichts gegen Kritik, wenn sie denn konstruktiv ist.

Gruß,
Beate


  


Betrifft: AW: @ Ulf von: Ulf
Geschrieben am: 26.08.2004 00:35:27

Ok, in dieser Konstellation gehts natürlich nicht.

"ein viel zu großer Bereich als nötig wird abgeklappert, um zum Ergebnis zu gelangen."
Wie gelangst du zu einer solchen Erkenntnis?

Bisher hast du noch nie reagiert, wenn ich eine Nachfrage zu eine deiner Antworten
hatte.

Ulf


  


Betrifft: @ Ulf von: Beate Schmitz
Geschrieben am: 26.08.2004 00:54:13

Hallo Ulf,

- ja, aber genau diese Konstellation hatte ich detailliert beschrieben! Wer lesen kann ist klar im Vorteil.

-"ein viel zu großer Bereich als nötig wird abgeklappert, um zum Ergebnis zu gelangen."
Wie gelangst du zu einer solchen Erkenntnis?
Ich kann dir da als kompetenten Ansprechpartner z.B. Robert Kunz nennen, häufig im Excel-Center. Durch ihn kam ich ursprünglich auf die Vorteile dynamisierter Bereiche.
Klar ersichtlich ist es doch für jeden Blinden, wenn Druckbereiche dynamisiert werden.
Es gibt natürlich verschieden Dynamisierungsmöglichkeiten (Makro/Namensdefinition/direkt in der Formel) - in dem Thread war ja nur ein passendes Beispiel.

- ich kann mich bewusst nur an einen Komment deinerseits erinnern, der bezog sich meiner Erinnerung nach auf meine Erklärung zu Autofilter trotz Blattschutz, bin aber nicht mehr ganz sicher. Du bemängeltest, wie ein Laie mit meiner Erklärung zu Recht kommen solle. Ich habe mir die Antwort gespart, da ich es genau andersrum empfand.

Aber deine Attacke da oben ging mir doch was weit.

So jetzt wird's höchste Zeit,
Gruß,
Beate


  


Betrifft: AW: @ Ulf von: Ulf
Geschrieben am: 26.08.2004 01:33:06

Na gut, lassen wir es dabei.

Ulf


  


Betrifft: AW: @ Ulf von: andre
Geschrieben am: 26.08.2004 05:46:12

Hallo Beate,
wenn nicht durch zusätzliche Daten bedingt einfalsches Ergebnis rauskommt, würde ich =SUMME(A2:A65536) bevorzugen, ist einfach einfacher ;-)
wenn es auf Zeit ankommt, scheint die Arrayformel schneller zu rechnen. Ich habe mal ein Blatt komplett gefüllt, da komme ich bei der Summenformel auf ca. 30s und mit Array auf ca. 12, wobei ich das nochmal mit der Uhr ;-) testen werde. Aber wie gesagt, die Summenformel ist einfacher und bei weniger Daten ist der Zeitfaktor nicht mehr relevant ...
in A1: {=SUMME(INDIREKT("A2:A"&MAX((A2:A65536<>"")*ZEILE(2:65536))))}


  


Betrifft: Entschuldigung von: Bastian
Geschrieben am: 26.08.2004 09:48:21

Bitte meine Unerfahrenheit zu entschuldigen. In der Angst und Zeitnot völlig ohne Antwort auszugehen habe ich durch das "Crossposting" (wieder was dazu gelernt) wohl unabsichtlich unfair gehandelt...

Nochmal vielen Dank für Eure Hilfe. Gruß,

Bastian


 

Beiträge aus den Excel-Beispielen zum Thema "Summenbereich automatisch verlängern / erkennen"