Microsoft Excel

Herbers Excel/VBA-Archiv

Daten filtrieren oder doch nicht

Betrifft: Daten filtrieren oder doch nicht von: Felix Dorfer
Geschrieben am: 26.08.2004 10:13:23

Hallo Leute,

ich hätte folgendes problem. habe 6 Produkte und die kann ich von mehr als 70 standorten beziehen und man benötigt sie eben auch an 70 andern standorten.

hab nun brav eine matrix bzw. mehrere von denen erstellt, wo die kosten von dort nach da angegeben sind. ich möchte jetzt ein arbeitsblatt erstellen, wo der user eingeben kann: dieses produkt für diesen standort und als ergebnis bekommt er den billigsten preis und noch die info (farbliche hinterlegung wie herkunftsstandort), woher das produkt bezogen wird.

hoff es ist verständlich genug. freu mich über jegliche unterstützung, zum gruße, felix

  


Betrifft: AW: Daten filtrieren oder doch nicht von: Günther Oppold
Geschrieben am: 26.08.2004 12:28:07

Hi Felix

leider weiß ich nicht, wie deine Tabellen aussehen.
Hier mein Lösungsvorschlag:

Tabelle2
 ABCDE
1Produktionskosten    
2     
3ArtikelStandort1Standort2Standort3 
41234564,35,23,8 
51234573,53,34 
6     
7     
8Frachtkosten    
9 Standort1Standort2Standort3 
10Standort1050,2670,33 
11Standort250,26030,44 
12Standort370,3330,440 
13     
14     
15Gesuchter Artikelfür Standort:Standort2 
16123457von Standort:Standort3zum Preis34,44
17     
18Hilfstabelle:alle StandorteProduktionskostenFrachtkostenSumme
19123457Standort13,550,2653,76
20 Standort2   
21 Standort3430,4434,44
Formeln der Tabelle
C16 : =INDEX(B19:B21;VERGLEICH(E16;E19:E21;0))
E16 : =MIN(E19:E21)
A19 : =A16
C19 : =WENN(B19=C$15;"";INDEX(A$4:D$5;VERGLEICH(A$19;A$4:A$5;0);VERGLEICH(B19;A$3:D$3;0)))
D19 : =WENN(B19=C$15;"";INDEX(A$10:D$12;VERGLEICH(C$15;A$10:A$12;0);VERGLEICH(B19;A$9:D$9;0)))
E19 : =WENN(C19="";"";C19+D19)
C20 : =WENN(B20=C$15;"";INDEX(A$4:D$5;VERGLEICH(A$19;A$4:A$5;0);VERGLEICH(B20;A$3:D$3;0)))
D20 : =WENN(B20=C$15;"";INDEX(A$10:D$12;VERGLEICH(C$15;A$10:A$12;0);VERGLEICH(B20;A$9:D$9;0)))
E20 : =WENN(C20="";"";C20+D20)
C21 : =WENN(B21=C$15;"";INDEX(A$4:D$5;VERGLEICH(A$19;A$4:A$5;0);VERGLEICH(B21;A$3:D$3;0)))
D21 : =WENN(B21=C$15;"";INDEX(A$10:D$12;VERGLEICH(C$15;A$10:A$12;0);VERGLEICH(B21;A$9:D$9;0)))
E21 : =WENN(C21="";"";C21+D21)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther<br><br> PS: falls Du mir eine Beispieldatei mailen willst: guenther_oppold@europe.pall.com