Microsoft Excel

Herbers Excel/VBA-Archiv

Hilfe zur Formelerstellung

Betrifft: Hilfe zur Formelerstellung von: Janina
Geschrieben am: 30.08.2004 14:28:14

hallo!

ich brauche Hilfe bei einer Formelberechnung zu folgender Tabelle:


Spalte A...........Spalte B
15.08.2004.......7
16.08.2004......-3
17.08.2004.......2
18.08.2004.......4



jetzt möchte ich eine Formel erstellen, die ungefähr so aussehen soll:
- wenn Datum größer/gleich 15.08.
- und Datum kleiner/gleich 18.08.
dann bitte alle Zahlen in Spalte B zusammenzählen aber nur wenn sie größer als 0 sind.
außerdem müsste gleichzeitig noch der Durchschnittswert von Spalte B errechnet werden.

Wenn mir jemand damit helfen kann, dann vielen Dank!

Gruß
Janina

  


Betrifft: AW: Hilfe zur Formelerstellung von: Wolfgang
Geschrieben am: 30.08.2004 14:44:00

Hallo Janina,

vielleicht klappt das so bei dir:

=SUMMEWENN(A1:A7;">14.08.2004";B1:B7)-SUMMEWENN(A1:A7;">18.08.2004";B1:B7)

das ganze eingeben und dann mit der Tastenkombination Strg+Umsch+Enter abschließen.

gruß
Wolfgang


  


Betrifft: AW: Hilfe zur Formelerstellung von: JRobert
Geschrieben am: 30.08.2004 15:25:30

Hallo Janina,
versuch's mal so:
in c1 steht Anfangsdatum
in d1 steht Endedatum
dann für die Summe ist die Formel:

{=SUMME(((A1:A100)>=C1)*((A1:A100)<=D1)*((B1:B100)>0)*B1:B100)}

und für den Mittelwert:
{=SUMME(((A1:A6)>=C1)*((A1:A6)<=D1)*((B1:B6)>0)*B1:B6)/SUMME(((A1:A6)>=C1)*((A1:A6)<=D1)*((B1:B6)>0))}


das sind Matrixforfel

grüß Robert