Microsoft Excel

Herbers Excel/VBA-Archiv

Problem bei einer Formel

Betrifft: Problem bei einer Formel von: Georg O.
Geschrieben am: 31.08.2004 11:39:48

Ich hatte vor Tagen schon mal einen Dienstplanentwurf reingestellt, der leider nicht mehr zu Verfügung steht. Nun bin ich dabei die TEchnik zu verfeinern.
Mein Ziel ist es das bei der Eingabe der Zeit in den dafür vorgesehenden Felder direkt errechnet wird wieviele der Stunden für die Tagesentlohnung, Nachtentlohnung und für Sonn- und Feiertagen gerechnet werden.
Nun hab ich versucht mit WENN zu arbeiten also


Tagschichtstunden:(06:00 Uhr bis 20:00)

C1=WENN(A1=SONNTAG;"0";WENN(ANFANGSZEIT>20:00;"0";WENN(ENDZEIT>20:00;20:00-Anfangszeit;WENN(ANFANGSZEIT>ENDZEIT; ....

und da verließen sie mich. Ich möchte errechnen z.B bei einer Schicht von 18:00 Uhr bis 06:00 Uhr wieviele Stunden in den "Tagesdienst" fallen ( in diesem Fall 2H. bei einer Spätschicht soll auch so verfahren werden (14:00 Uhr bis 22:00 Uhr= 2H Nachtdienst) Kann mir BITTE jemand helfen. Sonst Drehe ich durch, zumal ich auch noch die "NACHTSCHICHT", "SONN- und FEIERTAGE" Vor der Brust habe.

vielen vielen Dank

Georg O.

  


Betrifft: AW: Problem bei einer Formel von: Georg O
Geschrieben am: 31.08.2004 11:42:38

PS: In Zelle C1 sollen NUR die Tagesstunden auftauchen!! In Celle C2 die Nachtstunden u.s.w

Danke

Georg O.


  


Betrifft: AW: Problem bei einer Formel von: Dicky
Geschrieben am: 31.08.2004 13:56:01

Hallo Georg,

ich würde an Deiner Stelle mit mehrehren Hilfszeilen arbeiten, also z.B. in Feld C1 die Bedingung Wenn Anfangs- und Endzeit zwischen dann Anzahl Stunden = Tagschicht

in Feld C2 geht dann Wenn Zeit größer Ende dann Anzahl der stunden für diese Bedingung in Spätschicht.

Die gleiche Möglichkeit für alle anderen Schichten.

Auf diese Art erhältst Du viele Hilfsfelder,die Du einzeln prüfen (und hinterher einfach je Schicht) addieren kannst. Man kann sie ja ausblenden, wenn man sie nicht sehen will.
Alles in einer Formel wird zu unübersichtlich und ist bei Änderungen sehr schwer zu pflegen.

Ich hoffe,d er Ansatz hat Dir etwas geholfen.


Frank


  


Betrifft: AW: Problem bei einer Formel von: Georg O.
Geschrieben am: 31.08.2004 14:11:35

Danke ich werd´s mal auf die Art versuchen. Falls es klappt lass ich es euch wissen und Stell die fertige Tabelle hier rein.


Georg


 

Beiträge aus den Excel-Beispielen zum Thema "Problem bei einer Formel"