Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn-Formel

Betrifft: Wenn-Formel von: Esther Perl
Geschrieben am: 31.08.2004 16:52:42

Ich muss zwei mal pro Jahr über 500 Briefe anschreiben.
Ich möchte jede Person persönlich ansprechen, was sehr aufwendig ist.

Ich möchte, sofern es möglich ist, dieses Problem in der Exeltabelle mit der Wenn-Funktion lösen.

Z.B. Wenn in Zelle A2 "Herr" steht, dann kommt "Sehr geehrte Herr" und dann anschliessen der Name, der in Zelle C2 steht.
Wenn aber in Zelle A2 "Frau" steht, dann soll "Sehr geehrte Frau" und dann der Name, der in Zelle C2 steht.
Steht aber Familie in Zelle A2, dann "Sehr geehrte Familie und dann Zelle C2.
Das Resultat müsste dann jeweils in Zelle G2 kommen. (Sehr geehrter Herr plus den Namen)

Zelle A2 = Herr
Zelle C2 = Name
Zelle G2 = Sehr geehrter Herr Bruni

Ist so etwas möglich?


Ich weiss, ich könnte es auch anderst machen, aber wenn es möglich ist, würde ich es gerne auf diese Art machen.

Vielen herzliche Dank für Ihre Antwort.
Freundliche Grüsse

Esther Perl

  


Betrifft: AW: Wenn-Formel von: reinhard
Geschrieben am: 31.08.2004 16:59:42

Hi Esther,
probier mal folgende Formel in G2:
=wenn(a2="Herr";"SgHerr ";"")&wenn(a2="Frau";"SgFrau ";"")&wenn(a2="Familie";"SgFamilie ;"")& C2
Gruß
Reinhard


  


Betrifft: Vorschlag ohne WENN von: Grüße Boris
Geschrieben am: 31.08.2004 17:02:32

Hi Reinhard,

="Sehr geehrte"&LINKS("r";(A2="Herr"))&" "&A2&" "&C2

Grüße Boris


  


Betrifft: AW: Vorschlag ohne WENN von: reinhard
Geschrieben am: 31.08.2004 17:09:26

Hi Boris,
sehr clever ausgedacht. Naja, bin da nicht sehr gut, hab sogar die neue Funktion von Wolfgang überlesen :-)
Gruß
Reinhard



  


Betrifft: AW: Wenn-Formel von: Esther Perl
Geschrieben am: 31.08.2004 17:23:54

Hallo Reinhard, Boris und Wolfgang

Super, wie ihr das einfach so wisst! Ich habe versucht und gepröbelt - fast stundenlang - und ihr habt es in so kurze Zeit herausgefunden. Danke, vielen Dank!


  


Betrifft: AW: Wenn-Formel von: Wolfgang
Geschrieben am: 31.08.2004 17:01:57

Hallo Esther,

=VERKNÜPFEN(WENN(ODER(A2="Frau";A2="Familie");"Sehr geehrte ";"Sehr geehrter ");A2;" ";C2)

Gruß
Wolfgang


  


Betrifft: Oh - ne neue Funktion? ;-)) oT von: Boris
Geschrieben am: 31.08.2004 17:03:17

Grüße Boris


  


Betrifft: Tja, wer kann der kann ;-)) oT von: Wolfgang
Geschrieben am: 31.08.2004 17:07:08




  


Betrifft: AW: Wenn-Formel jetzt aber richtig von: Wolfgang
Geschrieben am: 31.08.2004 17:05:41

sorry,

so passts:

=VERKETTEN(WENN(ODER(A2="Frau";A2="Familie");"Sehr geehrte ";"Sehr geehrter ");A2;" ";C2)

wolfgang


  


Betrifft: fehlte ein Gänsefüsschen, diesmal richtig von: Reinhard
Geschrieben am: 31.08.2004 17:02:00

=WENN(A2="Herr";"SgHerr ";"")&WENN(A2="Frau";"SgFrau ";"")&WENN(A2="Familie";"SgFamilie";"")&C2
Gruß
Reinhard


  


Betrifft: AW: Wenn-Formel von: eck
Geschrieben am: 31.08.2004 18:03:16

Hi Esther,

versuch's mal damit

=WENN(A2="Frau";"Sehr geehrte Frau "&C2;WENN(A2="Herr";"Sehr geehrter Herr "&C2;
WENN(A2="Familie";"Sehr geehrte Familie "&C2;)))

Gruss eck


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn-Formel"