Microsoft Excel

Herbers Excel/VBA-Archiv

Datum und Monat

Betrifft: Datum und Monat von: Michael S.
Geschrieben am: 01.09.2004 12:07:24

Hallo zusammen,

ich habe eine Zelle in Excel, wo ich immer die letzte Änderung mit einem Datum festhalte.
In einer anderen Zelle soll automatisch der letzte Tag des Vormonat (Vormonat = Monat vor der letzten Aktualisierung) erscheinen.

Wie löse ich das?

Ich habe es mit der folgenden Formel versucht, aber damit bekomme ich nur 8 Monate... und ein Jahr hat schliesslich 12 Monate ;-)

=WENN(MONAT(D2)=7;"30.06.2004";WENN(MONAT(D2)=6;"31.05.2004";WENN(MONAT(D2)=5;"30.04.2004";WENN(MONAT(D2)=4;"31.03.2004";WENN(MONAT(D2)=3;"28.02.2004";WENN(MONAT(D2)=2;"31.01.2004";WENN(MONAT(D2)=1;"31.12.2003")))))))

Hat jemand eine Idee?

Danke,

Michael

  


Betrifft: =Datum(jahr(d2);Monat(d2);0) oT von: Uduuh
Geschrieben am: 01.09.2004 12:16:07




  


Betrifft: AW: =Datum(jahr(d2);Monat(d2);0) oT von: Michael S.
Geschrieben am: 01.09.2004 12:25:51

DANKE! KLAPPT SUPER!!!!

Michael


  


Betrifft: AW: Datum und Monat von: Harald Kapp
Geschrieben am: 01.09.2004 12:19:58

Hallo Michael,
wenn aktuelles Datum in A1, dann:

=DATUM(JAHR(EOMONTH(A1;-1));MONAT(EOMONTH(A1;-1));TAG(EOMONTH(A1;-1)))

Für die Funktion EOMONTH muss ggfls. das Analysis Toll Pack Add-In installiert sein



Gruß Harald