Microsoft Excel

Herbers Excel/VBA-Archiv

Zerlegung einer Zahl...

Betrifft: Zerlegung einer Zahl... von: Roland
Geschrieben am: 01.09.2004 13:25:03

Hallo Forum,
hier mein Problem:
Ich möchte eine Weg/Kostenrechnung durchführen, bei der die ersten 10KM 1€, ab 10KM 1,20€ berechnet werden. Also KM in eine Zelle, Kosten in die andere.
Inzwischen hab ich einen Knoten im Hirn und komme nicht mehr weiter...
Mein Ansatz war die Zerlegung der Zahl in Einer und Zehner usw.
Nur - wie bekomme ich das hin?
Ich denke, die Lösung ist recht einfach, aber ich bin im Moment zu verwirrt:-)
Hilfe!

Vielen Dank
Roland

  


Betrifft: AW: Zerlegung einer Zahl... von: magic
Geschrieben am: 01.09.2004 13:29:27

Hallo Roland,

meinst Du so (km-Wert in A1):

=wenn(a1<=10;a1;(a1-10)*1,2+10)

Gruß
Michael


  


Betrifft: AW: Zerlegung einer Zahl... von: Reinhard
Geschrieben am: 01.09.2004 13:30:54

Hi Roland,
=WENN(A3<=10;A3;10+(A3-10)*1,2)
Gruß
Reinhard


  


Betrifft: AW: Zerlegung einer Zahl... von: Roland
Geschrieben am: 01.09.2004 15:05:24

Ah, jetzt, ja...

Vielen Dank für die schnellen Antworten.
Manchmal steht man wirklich auf dem Schlauch...:-)

Gruß
Roland