Microsoft Excel

Herbers Excel/VBA-Archiv

Spez Filter

Betrifft: Spez Filter von: Gregor
Geschrieben am: 03.09.2004 11:34:07

Hallo

In Zelle C8 habe ich folgende Formel:
=WENN(C9=1;1; WENN(C9=2;2;WENN(C9=3;3;WENN(C9="alle";"";""))))
C9 füllt der User mit einer Liste 1; 2; 3; alle aus (Gültigkeit).

Mit folgender Filterfungktion (VBA) will ich nun die Code 1, 2, 3 oder alle in Kombination mit andern Kriterien in anderen Spalten filtern:

'--- filtert mit Spezialfilter
Range("A2:AD" & intLastRowFilter).AdvancedFilter Action:=xlFilterInPlace, _
CriteriaRange:=Sheets("Filtern").Range("A7:F8"), Unique:=False

Die Code 1 bis 3 funktioniert problemlos, während bei alle, also bei "" (dorch Formel) keine Zeilen angezeigt werden.

Woran kann das liegen? Evt. am Format?

Vielen Dank
Gregor

  


Betrifft: AW: Spez Filter von: DieterB
Geschrieben am: 04.09.2004 16:22:27

Hallo Gregor,

wenn in c9 "alle" steht, soll in B9 nix angezeigt werden.
Genau genommen sagt die Formel:
wenn in C9 1 steht, schreibe mir in C8 1
wenn in C9 2 steht, schreibe mir in C8 2
wenn in C9 3 steht, schreibe mir in C8 3
wenn in C9 "alle" steht, schreibe mir in C8 nix
und wenn keine Bedingung zutrifft (in C9 steht weder 1, noch 2, noch 3, noch "alle")
lasse C8 leer.

Gruß

DieterB


  


Betrifft: geschlossen - mit Link von: Björn B.
Geschrieben am: 05.09.2004 11:54:52

Fortsetzung siehe:

https://www.herber.de/forum/messages/479957.html

Gruß
Björn


 

Beiträge aus den Excel-Beispielen zum Thema "Spez Filter"