Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn ?? ! oder Wie auch immer :)

Betrifft: Wenn ?? ! oder Wie auch immer :) von: Hawk
Geschrieben am: 06.09.2004 10:37:44

Hallo
meine frage Ich möchte einen fragenbogen erstellen...
habe 4 felder zwei sind richtig und der rest halt nicht

A1 = wahr und ergibt (1 Punkt)
A2 = wahr und ergibt (1 Punkt)
A3 = Falsch ergibt ( 0 Punkte )
A4 = Falsch ergibt ( 0 Punkte )

so wie kann ich dieses abfragen ?
wenn ich nur ein Kreuz mache soll es keine punkte geben
wenn ich 3 oder 4 kreuze mache sollte es auch keine punkte geben
erst wenn ich beide richtig habe (A1+A2) = 2 Punkte
wie kann ich das machen ?
Danke schon mal
Hawk



  


Betrifft: AW: Wenn ?? ! oder Wie auch immer :) von: Russi
Geschrieben am: 06.09.2004 10:46:20

Hallo Hawk!

Vielleicht etwa so:

=WENN(UND(A1>"";A2>"");ANZAHL2(A1:A2))

Das ergibt 2 Punkte, wenn in A1 UND A2 was eingetragen ist.

Viele Grüße
Russi
www.Russi.de.tt


  


Betrifft: AW: Wenn ?? ! oder Wie auch immer :) von: M4rkus
Geschrieben am: 06.09.2004 10:49:45

Hallo,

=WENN(UND(C10=WAHR;C11=WAHR); 1;0)

so müsste das gehe


  


Betrifft: AW: Wenn ?? ! oder Wie auch immer :) von: Hawk
Geschrieben am: 06.09.2004 11:12:31

erstmal danke
aber leider geht das nicht mit den beiden formeln.. ?
ich bekomme wenn 3 oder alle 4 ankreuze immer noch die volle punkte anzahl

und das sollte er nicht....

vielleicht gibt es da noch eine möglichkeit ??

gruss
Hawk


  


Betrifft: AW: Wenn ?? ! oder Wie auch immer :) von: M4rkus
Geschrieben am: 06.09.2004 11:24:43

Hallo,

versuch es mit geschachtelten wenn:

wenn(a1=wahr;Wenn(a2=wahr;wenn(a3=falsch;WENN(a4=falsch;1;0)))) so jetzt bekommst du nur einen punkt wenn a1 und a2 wahr sind und a3 und a4 falsch sind soblad sich eines der felder ändert bekommt man keinen punkt mehr

Gruß Markus


  


Betrifft: AW: Wenn ?? ! oder Wie auch immer :) von: Hawk
Geschrieben am: 06.09.2004 20:16:33

danke nochmals

es geht jetzt... :-)

:)

Gruß
Hawk