Microsoft Excel

Herbers Excel/VBA-Archiv

Als leere Zelle erkennen

Betrifft: Als leere Zelle erkennen von: Esther
Geschrieben am: 07.09.2004 17:14:03

Hallo alle, die meine Frage lesen

Ist A3 eine leere Zelle, dann sollte in G3 "Sehr geehrte Damen" "Sehr geehrte Herren" stehen, inkl. Zeilenschaltung nach Damen. Ist so was mit der Wennfunkion möglich?

Vielen Dank an die Helfer

Gruss Esther

  


Betrifft: AW: Als leere Zelle erkennen von: ransi
Geschrieben am: 07.09.2004 17:16:21

hallo

mit wenn() ist gut, aber was ist eine zeilenschaltung?

ransi


  


Betrifft: AW: Als leere Zelle erkennen von: th.heinrich
Geschrieben am: 07.09.2004 17:22:47

hallo Esther,

=WENN(A3="";"Sehr geehrte Damen
Sehr geehrte Herren";"nicht leer")

den ZEILENUMBRUCH nach damen mit ALT+ENTER einfuegen.

gruss thomas


  


Betrifft: AW: Als leere Zelle erkennen von: Esther
Geschrieben am: 07.09.2004 17:26:12

Hallo ransi

Danke für deinen Rat.
Zeilenschaltung ist für mich, wenn ich in Excel mit "Alt und Enter" Text in eine neue Zeile, aber in der gleichen Zelle schreiben kann

Esther


  


Betrifft: AW: Als leere Zelle erkennen von: Esther
Geschrieben am: 07.09.2004 17:30:15

Hallo ransi

Danke für deinen Rat.
Zeilenschaltung ist für mich, wenn ich in Excel mit "Alt und Enter" Text in eine neue Zeile, aber in der gleichen Zelle schreiben kann

Esther


  


Betrifft: ...und wieder hab ich was gelernt. o.T. von: ransi
Geschrieben am: 07.09.2004 17:35:29




  


Betrifft: AW: Als leere Zelle erkennen von: Wolf-Dieter
Geschrieben am: 07.09.2004 17:30:36

Hallo Esther,

in G3 folgende Formel schreiben:
=WENN(A3="";VERKETTEN("Sehr geehrte Damen";ZEICHEN(10);"Sehr geehrte Herren");"")

Dann muß allerdings die Zelle (oder die Zellen, wenn es mehrere sind) noch formatiert werden auf Format - Ausrichtung - Zeilenumbruch


  


Betrifft: AW: Als leere Zelle erkennen von: Esther
Geschrieben am: 07.09.2004 17:48:41

Hallo Wolf-Dieter
Was bedeutet ZEICHEN(10)?

Danke
Esther


  


Betrifft: AW: Als leere Zelle erkennen von: Wolf-Dieter
Geschrieben am: 07.09.2004 17:51:28

... das ist ein Steuerzeichen und steht für New Line.


  


Betrifft: AW: Als leere Zelle erkennen von: Esther
Geschrieben am: 07.09.2004 17:59:35

Hallo nocheinmal

Wenn ich diese Formel eingebe, kommt dann Sehr geehrte Damen Sehr geehrte HerrenPeng

=WENN(A2="Herr";"Sehr geehrter Herr ";"")&WENN(A2="Frau";"Sehr geehrte Frau ";"")&WENN(A2="Familie";"Sehr geehrte Familie ";"")&WENN(A2="";VERKETTEN("Sehr geehrte Damen";
ZEICHEN(10);"Sehr geehrte Herren");"")&C2

Dort, wo nur Frau oder Herr oder Familie steht, kommt der Nachname dazu, wo aber Sehr geehrte Damen und Sehr geehrte Herren stehen soll, sollte kein Nachname stehen. Geht so was?
Vielen herzlichen Dank

Gruss Esther


  


Betrifft: AW: Als leere Zelle erkennen von: Wolf-Dieter
Geschrieben am: 07.09.2004 18:07:05

...
schreibe doch das den Inhalt von C2 gleich mit in die Formel, also z.B.
=wenn(A2="Herr";verketten("Sehr geehrter Herr ";C2);"")&wenn ... usw.


  


Betrifft: AW: Als leere Zelle erkennen von: FP
Geschrieben am: 07.09.2004 19:36:07

Hi Esther,

das mit Zeichen(10) funktioniert nicht!

probier mal diese Formel:

Tabelle2
 AB
1HerrSehr geehrter Herr
2FrauSehr geehrte Frau
3FamilieSehr geehrte Familie
4 Sehr geehrte Damen Sehr geehrte Herren
Formeln der Tabelle
B1 : ="Sehr geehrte"&WENN(A1="";" Damen "&"Sehr geehrte Herren";WENN(A1="Herr";"r";"")&" "&A1)
B2 : ="Sehr geehrte"&WENN(A2="";" Damen "&"Sehr geehrte Herren";WENN(A2="Herr";"r";"")&" "&A2)
B3 : ="Sehr geehrte"&WENN(A3="";" Damen "&"Sehr geehrte Herren";WENN(A3="Herr";"r";"")&" "&A3)
B4 : ="Sehr geehrte"&WENN(A4="";" Damen "&"Sehr geehrte Herren";WENN(A4="Herr";"r";"")&" "&A4)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Markiere die Spalte in der diese Formel steht
klick mit rechter Maustaste - Zellen formatieren - Ausrichtung - Häkchen vor Zeilenumbruch
Spalte so breit machen, dass die 2 Zeilen untereinander geschrieben werden

Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Als leere Zelle erkennen von: FP
Geschrieben am: 08.09.2004 07:37:28

Hi Esther,

hatte gestern offenbar nicht meinen besten Tag ;-)

Wenn der Zeilenumbruch aktiv ist, funktioniert ZEICHEN(10) natürlich !!!

Servus aus dem Salzkammergut
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "Als leere Zelle erkennen"