Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt

Betrifft: Summenprodukt von: Schorsch
Geschrieben am: 08.09.2004 22:31:20

Hallo Leute,

habe folgendes Problem:

Ich möchte für einen bestimmten Monat im Jahr die Zeitwerte in den Spalten Aktiv(B) und Passiv(C) aufsummieren. Dabei soll der Monat und das Jahr aus dem Datum(A) gewonnen werden.

z.B. Summiere alle Zeiten in Spalte B und C die dem Monat Januar des Jahres 2001 aus Spalte A entsprechen.

Erstmal Danke !

Schorsch

  


Betrifft: AW: Summenprodukt von: Ramses
Geschrieben am: 08.09.2004 22:39:40

Hallo

etwa so :

Tabelle1
 ABCDEF
101.01.20041 Ergebnis für Januar 2004  
201.05.20041 2  
301.02.20041    
401.01.20041    
5      
6      
Formeln der Tabelle
D2 : =SUMMENPRODUKT((MONAT(A1:A10)=1)*(JAHR(A1:A10)=2004)*(B1:B10))
 




Gruss Rainer


  


Betrifft: AW: Summenprodukt von: Schorsch
Geschrieben am: 08.09.2004 22:47:10

Servus,

schon nich schlecht. Nur muss ich zwei Spalten aufsummieren. Ich hab das auch schon mit der Summenprodukt Funktion beprobt, aber die zeigt mir ein leeres Feld ??? Nur wenn ich einen Monat wähle (z.B. Januar=1) dann rechnet mir Excel für alle Jahre die Zeiten einer Spalte aus. :-(

Hilfe !

Schorsch


  


Betrifft: AW: Summenprodukt von: Ramses
Geschrieben am: 08.09.2004 22:58:20

Hallo

was hindert dich daran die beiden Spalten zu addieren ?

Tabelle1
 ABCDEF
101.01.200411 Ergebnis für Januar 2004 
201.05.200411 4 
301.02.200411   
401.01.200411   
5      
Formeln der Tabelle
E2 : =SUMMENPRODUKT((MONAT(A1:A10)=1)*(JAHR(A1:A10)=2004)*(B1:B10))+SUMMENPRODUKT((MONAT(A1:A10)=1)*(JAHR(A1:A10)=2004)*(C1:C10))
 




Gruss Rainer


  


Betrifft: AW: Summenprodukt von: Beate Schmitz
Geschrieben am: 08.09.2004 23:03:30

Hallo Schorsch und Rainer,

was spricht denn dagegen, die Erweiterung um die Spalte in der existenten Formel zu machen?

Tabelle1
 ABCDE
1 Summe:18Monat:1
2 AktivPassivJahr:2004
301.01.200482  
401.05.200475  
501.02.200444  
601.01.200453  
Formeln der Tabelle
C1 : =SUMMENPRODUKT((MONAT(A3:A12)=E1)*(JAHR(A3:A12)=E2)*(B3:C12))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Schorch, wenn du Suchmonat und Suchjahr in Zellen eingibst, kannst du die Formel dynamischer machen. Hier in E1 und E2.

Gruß,
Beate


  


Betrifft: AW: Summenprodukt von: Beate Schmitz
Geschrieben am: 08.09.2004 23:03:57

Hallo Schorsch und Rainer,

was spricht denn dagegen, die Erweiterung um die Spalte in der existenten Formel zu machen?

Tabelle1
 ABCDE
1 Summe:18Monat:1
2 AktivPassivJahr:2004
301.01.200482  
401.05.200475  
501.02.200444  
601.01.200453  
Formeln der Tabelle
C1 : =SUMMENPRODUKT((MONAT(A3:A12)=E1)*(JAHR(A3:A12)=E2)*(B3:C12))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Schorch, wenn du Suchmonat und Suchjahr in Zellen eingibst, kannst du die Formel dynamischer machen. Hier in E1 und E2.

Gruß,
Beate


  


Betrifft: AW: Summenprodukt von: Ramses
Geschrieben am: 08.09.2004 23:12:20

Hallo Beate

"...was spricht denn dagegen, die Erweiterung um die Spalte in der existenten Formel zu machen?.."

Nichts :-)

Die andere Version ist mir einfach zuerst eingefallen :-)

Gruss Rainer


  


Betrifft: AW: Summenprodukt von: Schorsch
Geschrieben am: 08.09.2004 23:07:02

Hallo Rainer,

ich mach irgendwas verkehrt. Die Fomel sollte eigentlich die Lösung sein!? Bei mir bleibt aber die Zelle leer, wenn ich Enter drücke?
Ist es möglich, dass es Probleme gibt, wenn einige Zellen die summiert werden leer sind ? z.B. Wenn in Spalte B der Wert 1 steht, darf in Spalte C nichts stehen !

Gruß

Schorsch


  


Betrifft: AW: Summenprodukt von: Beate Schmitz
Geschrieben am: 08.09.2004 23:15:44

Hallo Schorsch,

weiß nicht, ob Rainer noch hier ist. Ich habe es mit meiner Vorschlagsdatei probiert. Meine Formel rechnet weiter richtig, wenn ich eine Zelle leere. Und Rainers ebenfalls. Startet deine Tabelle vielleicht nicht in Zeile 1? Das musst du anpassen.

Gruß,
Beate


  


Betrifft: AW: Summenprodukt von: Schorsch
Geschrieben am: 08.09.2004 23:23:09

Hallo Beate,

nachdem ich Nullwerte anzeigen eingestellt habe, wird mir 00:00 angezeigt. Ich habe den Start schon um eine Zeile tiefer gelegt (Beginne hier mit 3). Wenn ich nur einen Monat nehme, wird auch was ausgerechnet. Die kombination aus Jahr und Monat klappt nich ?!

Gruß

Schorsch


  


Betrifft: AW: Summenprodukt von: Ramses
Geschrieben am: 08.09.2004 23:26:37

Hallo

"...wird mir 00:00 angezeigt. ..."

Da ist die Spalte mit dem Format "Uhrzeit" belegt.
Formatier die Spalte mal mit "Format - Zelle - Standard"

Gruss Rainer


  


Betrifft: AW: Summenprodukt von: Ramses
Geschrieben am: 08.09.2004 23:16:52

Hallo

wie du siehst, funktioniert die Formel ja, auch bei Beate.
Du darfst keine Spaltenbezeichnungen verwenden wie z.B. A:A. Das geht nicht

"..Wenn in Spalte B der Wert 1 steht, darf in Spalte C nichts stehen !..."

Das war in der Frage auch nicht gefordert.
Da musst du schon selbst schauen, dass die Eingaben richtig gemacht werden :-)

Gegen fehlerhafte Eingaben, ist keine Formel gefeit.

Gruss Rainer


  


Betrifft: AW: Summenprodukt von: Schorsch
Geschrieben am: 09.09.2004 09:36:55

Hallo,

Es läuft !

Ich hab einen blöden Fehler gemacht. Excel hat mir 0 angezeigt, weil auch keine Daten in dem Monat und dem Jahr vorhanden waren !!! Bei ca. 2000 Zeilen kann man ja mal die Ü verlieren, oder ?

Danke nochmal !

Schorsch