Microsoft Excel

Herbers Excel/VBA-Archiv

WENN Formel?

Betrifft: WENN Formel? von: Tom
Geschrieben am: 10.09.2004 12:35:40

Hallo zusammen,
ich kenn mich in Excel nich gut aus und habe folgendes Problem:

Ich möchte über eine WENN Formel eine Zelle Vergleichen in der m² angegeben sind,und zwar z.B.: 0,75 m² (die Bezeichnung m² steht in einer anderen Zelle).
In einer anderen Tabelle habe ich eine Spalte in der von 1 bis 5 m² stehen.
Also Zelle A1=1,Zelle A2=2,u.s.w.
Jetzt soll der Wert der in Zelle z.B.: N13 steht, in dem Fall 0,75 mit der andern Tabelle verglichen werden und wenn dieser unter 1 liegt soll er den wert Null ausgeben und wenn nicht die hinter den 1 bis 5 m² stehenden Prozente.
Das wollte ich mit der Formel WENN N13 kleiner als 1 dann...sonst..
Leider erkennt er Null, also die 0,75 nicht kleiner als 1 an...
Was kann ich eingeben damit Excel erkennt, das was alles ab 0,ist, z.B.: 0,75 kleiner als 1 ist?

Vieken Dank im voraus...

Gruß Tom

  


Betrifft: AW: WENN Formel? von: ransi
Geschrieben am: 10.09.2004 12:42:09

hallo tom

kannst du mal die tabelle hochladen?

ransi


  


Betrifft: AW: WENN Formel? von: Dieter.K
Geschrieben am: 10.09.2004 12:42:44

Hallo Tom,

ich denke, Deine Zelle mit dem Inhalt 0,75 ist nicht als ZAHL sonder STANDARDFORMAT formatiert.

Gruß
Dieter.K


  


Betrifft: AW: WENN Formel? von: Dieter.K
Geschrieben am: 10.09.2004 12:47:58

Sorry, nicht STANDARDFORMAT sondern TEXT.
Format sollte ZAHL oder STANDARD sein.

Gruß
Dieter.K


  


Betrifft: AW: WENN Formel? von: ..
Geschrieben am: 10.09.2004 17:13:08

Lebst du noch ich dachte du bist schon kalt


  


Betrifft: AW: WENN Formel? von: Tom
Geschrieben am: 10.09.2004 18:14:19

Hallo vielen Dank, für die schnelle Antwort...
Es lag an dem Format der Zelle und an dem DANN WERT der musste O sein.

Gruß Tom


  


Betrifft: AW: WENN Formel? von: Günther Oppold
Geschrieben am: 10.09.2004 12:47:27

Hallo Tom,

Werte aus einer "Stamm-"Tabelle auslesen macht man am besten mit einem Verweis.
die Zellformatierung mit m² kannst Du auch in 1 Zelle machen. Markiere die Zelle,
FORMAT - Zelle Formatieren - benutzerdefiniert - in das obere Feld eingeben: 0,00 "m²"

so erscheint die Zahl mit der Formatierung m², kann aber dennoch für Berechnungen weiter benutzt werden:
Tabelle3
 ABC
11,00 m²2 
22,00 m²4 
33,00 m²6 
44,00 m²8 
55,00 m²10 
6   
7   
8   
9 0,75 m²0
10 3,70 m²6
11 5,00 m²10
Formeln der Tabelle
C9 : =WENN(B9<1;0;SVERWEIS(B9;A$1:B$5;2;1))
C10 : =WENN(B10<1;0;SVERWEIS(B10;A$1:B$5;2;1))
C11 : =WENN(B11<1;0;SVERWEIS(B11;A$1:B$5;2;1))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

  


Betrifft: AW: WENN Formel? von: Tom
Geschrieben am: 10.09.2004 19:21:17

Danke für Deine Anwort, mit den Zellen Formatieren wusste ich auch noch nicht..
Wieder etwas gelernt...

Gruß Tom


  


Betrifft: AW: WENN Formel? von: Gert Seler
Geschrieben am: 10.09.2004 13:08:01

Hallo Tom,
folgende Formel :=WENN(A1<1;0;SVERWEIS(A1;Blatt2!A1:B5;2;FALSCH)
Aktiv Blatt1. In A1 steht der Wert; Formel=WENN A1 <1; (kleiner1)DANN schreibe 0
SONST SVERWEIS(A1;Blatt2! Bereich A1 bis B5 (in A 1-5; in B die% für A1-A5); suche
in der 2ten Spalte (B);Falsch)
das sollte klappen.
mfg
Gert


  


Betrifft: @Gert von: Uduuh
Geschrieben am: 10.09.2004 13:17:36

Hallo Gert,
das klappt nicht. Was ist, wenn der Wert z.B. 1,3 ist? Dann kriegst du #NV.
Der Parameter 'Falsch' muss weg, dann wird die %-Zahl, die 1 zugewiesen ist geliefert.
Wenn in die Tabelle noch Menge 0 mit Prozentzahl 0 aufgenommen wird, liefert
=SVerweis(A1;Tabelle2!$A$1:$B$6;2)
immer das richtige Ergebnis, nämlich immer die zur nächst niedrigeren gefundenen Menge gefundenen Prozente.

Gruß aus' Pott
Udo


  


Betrifft: AW: @Gert von: Tom
Geschrieben am: 10.09.2004 19:06:56

Vielen Dank,es klappt soweit jetzt aber ich habe etwas nicht bedacht vorher...

In der Tabelle2 sind nur m² von 1 bis 5 angegeben und denen sind 2,5%,5%,10%,15% und 20% zugeordnet.
Mit Eurer Hilfe habe ich in der Formel die unter 1m² erschlagen, weil 0% angegeben werden soll.
Kann man in der selben Formel folgendes dazu packen?:
Alles was unter 1m² liegt in Zelle A1 ist ja Null.
Alles ab 1m² bis 2m² soll 2,5% ab 2m² bis 3m² soll 5% ab 3m² bis 4m² soll 10% ab 4m² bis 5m² soll 15% und ab 5m² soll der SVERWEIS 20% zuordnen.
Da ich in Zelle A1 unterschiedliche m² bekomme z.B.: 1,63 stehe ich vor dem Problem der Zuordnug der Prozente da SVERWEIS diesen ja nicht findet.

Ich beschäftige mich mit Excel gerne und probiere selber erst viel rum.
Doch es fehlt mir hierfür noch einiges an Grundwissen über Formeln, deswegen freue ich mich über dieses Forum um so mehr.

Danke für Eure Hife...

Gruß Tom


  


Betrifft: AW: @Gert von: Tom
Geschrieben am: 10.09.2004 20:43:46

Hallo jetzt klappt es wie Udo es gesagt hat, mit dem nächst kleineren Wert,wenn der andere nicht gefunden wird,ich hatte ein Simikolon am Ende des SVERWEISES stehen,hinter der 2;Falsch hatte ich weggenommen aber das Simikolon nicht.
Danke noch mal...

Gruß Tom


  


Betrifft: AW: WENN Formel? von: Tom
Geschrieben am: 10.09.2004 18:20:28

Danke für die Anleitung,die O fehlte auch bei mir als Dann WERT.
Bin jetzt einen großen Schritt weiter.



Gruß Tom


 

Beiträge aus den Excel-Beispielen zum Thema "WENN Formel?"